<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>Police must stop killing Black people in America &ndash; Florida Courier</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://flcourier.com/xmlrpc.php" />
    <meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<!-- Google Tag Manager for WordPress by gtm4wp.com -->
<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
//]]>
</script>
<!-- End Google Tag Manager for WordPress by gtm4wp.com --><link rel="icon" type="image/png" href="https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/uploads/2020/01/FCfav.png">
	<!-- This site is optimized with the Yoast SEO plugin v16.2 - https://yoast.com/wordpress/plugins/seo/ -->
	<link rel="canonical" href="https://flcourier.com/police-must-stop-killing-black-people-in-america/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Police must stop killing Black people in America &ndash; Florida Courier" />
	<meta property="og:description" content="America is at war with Black People, and people of color. How could a credible Minneapolis police department put out a factual press release, which was a complete lie, and had no truth in it? “Man Dies after Medical Incident during Police Intervention,” says the Minneapolis police department concerning George Floyd’s death. This is an [&hellip;]" />
	<meta property="og:url" content="https://flcourier.com/police-must-stop-killing-black-people-in-america/" />
	<meta property="og:site_name" content="Florida Courier" />
	<meta property="article:publisher" content="https://www.facebook.com/flcourier/" />
	<meta property="article:published_time" content="2021-04-30T12:49:48+00:00" />
	<meta property="og:image" content="https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/uploads/2019/02/Roger-Caldwell.jpg" />
	<meta property="og:image:width" content="580" />
	<meta property="og:image:height" content="339" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@flcourier" />
	<meta name="twitter:site" content="@flcourier" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="FCEditor5">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="4 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://flcourier.com/#organization","name":"Florida Courier","url":"https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/","sameAs":["https://www.facebook.com/flcourier/","https://twitter.com/flcourier"],"logo":{"@type":"ImageObject","@id":"https://flcourier.com/#logo","inLanguage":"en-US","url":"https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/uploads/2017/08/fc_logo140x48-2.jpg?time=1617947968","contentUrl":"https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/uploads/2017/08/fc_logo140x48-2.jpg?time=1617947968","width":140,"height":48,"caption":"Florida Courier"},"image":{"@id":"https://flcourier.com/#logo"}},{"@type":"WebSite","@id":"https://flcourier.com/#website","url":"https://flcourier.com/","name":"Florida Courier","description":"Sharing Black Life, Statewide","publisher":{"@id":"https://flcourier.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://flcourier.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/police-must-stop-killing-black-people-in-america/#primaryimage","inLanguage":"en-US","url":"https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/uploads/2019/02/Roger-Caldwell.jpg?time=1619958089","contentUrl":"https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/uploads/2019/02/Roger-Caldwell.jpg?time=1619958089","width":580,"height":339},{"@type":"WebPage","@id":"https://flcourier.com/police-must-stop-killing-black-people-in-america/#webpage","url":"https://flcourier.com/police-must-stop-killing-black-people-in-america/","name":"Police must stop killing Black people in America &ndash; Florida Courier","isPartOf":{"@id":"https://flcourier.com/#website"},"primaryImageOfPage":{"@id":"https://flcourier.com/police-must-stop-killing-black-people-in-america/#primaryimage"},"datePublished":"2021-04-30T12:49:48+00:00","dateModified":"2021-04-30T12:49:48+00:00","breadcrumb":{"@id":"https://flcourier.com/police-must-stop-killing-black-people-in-america/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://flcourier.com/police-must-stop-killing-black-people-in-america/"]}]},{"@type":"BreadcrumbList","@id":"https://flcourier.com/police-must-stop-killing-black-people-in-america/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://flcourier.com/","url":"https://flcourier.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@id":"https://flcourier.com/police-must-stop-killing-black-people-in-america/#webpage"}}]},{"@type":"Article","@id":"https://flcourier.com/police-must-stop-killing-black-people-in-america/#article","isPartOf":{"@id":"https://flcourier.com/police-must-stop-killing-black-people-in-america/#webpage"},"author":{"@id":"https://flcourier.com/#/schema/person/b540b4eb307afa10b224aa6a1748db76"},"headline":"Police must stop killing Black people in America","datePublished":"2021-04-30T12:49:48+00:00","dateModified":"2021-04-30T12:49:48+00:00","mainEntityOfPage":{"@id":"https://flcourier.com/police-must-stop-killing-black-people-in-america/#webpage"},"commentCount":0,"publisher":{"@id":"https://flcourier.com/#organization"},"image":{"@id":"https://flcourier.com/police-must-stop-killing-black-people-in-america/#primaryimage"},"keywords":["Black people in America","George Floyd\u2019s death","killing of Black people","POLICE","Roger Caldwell"],"articleSection":["COLUMNISTS"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://flcourier.com/police-must-stop-killing-black-people-in-america/#respond"]}]},{"@type":"Person","@id":"https://flcourier.com/#/schema/person/b540b4eb307afa10b224aa6a1748db76","name":"FCEditor5","image":{"@type":"ImageObject","@id":"https://flcourier.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/f80538f48b7968f437d07064431c4202?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/f80538f48b7968f437d07064431c4202?s=96&d=mm&r=g","caption":"FCEditor5"}}]}</script>
	<!-- / Yoast SEO plugin. -->


<script type='application/javascript'>console.log('PixelYourSite Free version 8.1.0');</script>
<link rel='dns-prefetch' href='//use.fontawesome.com' />
<link rel='dns-prefetch' href='//cdn.jsdelivr.net' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Florida Courier &raquo; Feed" href="https://flcourier.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Florida Courier &raquo; Comments Feed" href="https://flcourier.com/comments/feed/" />
<link rel='preconnect' href='https://secureservercdn.net' crossorigin />
<link rel="alternate" type="application/rss+xml" title="Florida Courier &raquo; Police must stop killing Black people in America Comments Feed" href="https://flcourier.com/police-must-stop-killing-black-people-in-america/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/secureservercdn.net\/198.71.233.65\/7p3.923.myftpupload.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=598b6385a0d101819a78886948270e2e&time=1619958089"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='fontawesome_v4_shim_style-css'  href='https://use.fontawesome.com/releases/v5.3.1/css/v4-shims.css?ver=598b6385a0d101819a78886948270e2e' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='https://use.fontawesome.com/releases/v5.3.1/css/all.css?ver=598b6385a0d101819a78886948270e2e' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-includes/css/dist/block-library/style.min.css?ver=598b6385a0d101819a78886948270e2e&#038;time=1619958089' type='text/css' media='all' />
<link rel='stylesheet' id='wpdm-font-awesome-css'  href='https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/plugins/download-manager/assets/fontawesome/css/all.min.css?ver=598b6385a0d101819a78886948270e2e&#038;time=1619958089' type='text/css' media='all' />
<link rel='stylesheet' id='wpdm-front-bootstrap-css'  href='https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/plugins/download-manager/assets/bootstrap/css/bootstrap.min.css?ver=598b6385a0d101819a78886948270e2e&#038;time=1619958089' type='text/css' media='all' />
<link rel='stylesheet' id='wpdm-front-css'  href='https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/plugins/download-manager/assets/css/front.css?ver=598b6385a0d101819a78886948270e2e&#038;time=1619958089' type='text/css' media='all' />
<link rel='stylesheet' id='photocrati-image_protection-css-css'  href='https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/plugins/nextgen-gallery-pro/modules/image_protection/static/custom.css?ver=598b6385a0d101819a78886948270e2e&#038;time=1619958089' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-multi-purpose-css'  href='https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=819b7f9b02b0195f80e3eab970f44973x&#038;time=1619958089' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900&#038;display=swap&#038;ver=10.2' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/themes/Newspaper/style.css?ver=10.2&#038;time=1619958089' type='text/css' media='all' />
<style id='td-theme-inline-css' type='text/css'>
    
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    
	
</style>
<link rel='stylesheet' id='nextgen_widgets_style-css'  href='https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/widget/static/widgets.css?ver=3.9.3&#038;time=1619958089' type='text/css' media='all' />
<link rel='stylesheet' id='nextgen_basic_thumbnails_style-css'  href='https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/nextgen_basic_gallery/static/thumbnails/nextgen_basic_thumbnails.css?ver=3.9.3&#038;time=1619958089' type='text/css' media='all' />
<link rel='stylesheet' id='nextgen_basic_slideshow_style-css'  href='https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/nextgen_basic_gallery/static/slideshow/ngg_basic_slideshow.css?ver=3.9.3&#038;time=1619958089' type='text/css' media='all' />
<link rel='stylesheet' id='td-legacy-framework-front-style-css'  href='https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/css/td_legacy_main.css?ver=819b7f9b02b0195f80e3eab970f44973x&#038;time=1619958089' type='text/css' media='all' />
<link rel='stylesheet' id='td-standard-pack-framework-front-style-css'  href='https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/plugins/td-standard-pack/Newspaper/assets/css/td_standard_pack_main.css?ver=f3d6322e6f953bf07f46586e1d97917d&#038;time=1619958089' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css'  href='https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/plugins/td-composer/legacy/Newspaper/includes/demos/local_news/demo_style.css?ver=10.2&#038;time=1619958089' type='text/css' media='all' />
<link rel='stylesheet' id='tdb_front_style-css'  href='https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/plugins/td-cloud-library/assets/css/tdb_less_front.css?ver=c8cba5620a72d5b299fa8f62aeca6adfx&#038;time=1619958089' type='text/css' media='all' />
<script type='text/javascript' src='https://use.fontawesome.com/releases/v5.3.1/js/v4-shims.js?ver=5.3.1' id='fontawesome_v4_shim-js'></script>
<script type='text/javascript' defer integrity="sha384-kW+oWsYx3YpxvjtZjFXqazFpA7UP/MbiY4jvs+RWZo2+N94PFZ36T6TFkc9O3qoB" crossorigin="anonymous" data-auto-replace-svg="false" data-keep-original-source="false" data-search-pseudo-elements src='https://use.fontawesome.com/releases/v5.3.1/js/all.js?ver=5.3.1' id='fontawesome-js'></script>
<script type='text/javascript' src='https://cdn.jsdelivr.net/npm/js-cookie@2.2.0/src/js.cookie.min.js?ver=2.2.0' id='js-cookie-js'></script>
<script type='text/javascript' src='https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1&#038;time=1619958089' id='jquery-core-js'></script>
<script type='text/javascript' src='https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2&#038;time=1619958089' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/plugins/download-manager/assets/bootstrap/js/bootstrap.bundle.min.js?ver=598b6385a0d101819a78886948270e2e&#038;time=1619958089' id='wpdm-front-bootstrap-js'></script>
<script type='text/javascript' id='frontjs-js-extra'>
/* <![CDATA[ */
var wpdm_url = {"home":"https:\/\/flcourier.com\/","site":"https:\/\/flcourier.com\/","ajax":"https:\/\/flcourier.com\/wp-admin\/admin-ajax.php"};
var wpdm_asset = {"spinner":"<i class=\"fas fa-sun fa-spin\"><\/i>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/plugins/download-manager/assets/js/front.js?ver=3.1.23&#038;time=1619958089' id='frontjs-js'></script>
<script type='text/javascript' src='https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/plugins/download-manager/assets/js/chosen.jquery.min.js?ver=598b6385a0d101819a78886948270e2e&#038;time=1619958089' id='jquery-choosen-js'></script>
<script type='text/javascript' src='https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/plugins/nextgen-gallery-pro/modules/image_protection/static/pressure.js?ver=598b6385a0d101819a78886948270e2e&#038;time=1619958089' id='pressure-js'></script>
<script type='text/javascript' id='photocrati-image_protection-js-js-extra'>
/* <![CDATA[ */
var photocrati_image_protection_global = {"enabled":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/plugins/nextgen-gallery-pro/modules/image_protection/static/custom.js?ver=2.2.0&#038;time=1619958089' id='photocrati-image_protection-js-js'></script>
<link rel="https://api.w.org/" href="https://flcourier.com/wp-json/" /><link rel="alternate" type="application/json" href="https://flcourier.com/wp-json/wp/v2/posts/34206" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://flcourier.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-includes/wlwmanifest.xml?time=1619958089" /> 

<link rel='shortlink' href='https://flcourier.com/?p=34206' />
<link rel="alternate" type="application/json+oembed" href="https://flcourier.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fflcourier.com%2Fpolice-must-stop-killing-black-people-in-america%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://flcourier.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fflcourier.com%2Fpolice-must-stop-killing-black-people-in-america%2F&#038;format=xml" />

        <script>
            var wpdm_site_url = 'https://flcourier.com/';
            var wpdm_home_url = 'https://flcourier.com/';
            var ajax_url = 'https://flcourier.com/wp-admin/admin-ajax.php';
            var wpdm_ajax_url = 'https://flcourier.com/wp-admin/admin-ajax.php';
            var wpdm_ajax_popup = '0';
        </script>
        <style>
            .wpdm-download-link.btn.btn-primary.{
                border-radius: 4px;
            }
        </style>


        <meta name="generator" content="Site Kit by Google 1.31.0" /><script type='text/javascript' data-cfasync='false'>var _mmunch = {'front': false, 'page': false, 'post': false, 'category': false, 'author': false, 'search': false, 'attachment': false, 'tag': false};_mmunch['post'] = true; _mmunch['postData'] = {"ID":34206,"post_name":"police-must-stop-killing-black-people-in-america","post_title":"Police must stop killing Black people in America","post_type":"post","post_author":"23","post_status":"publish"}; _mmunch['postCategories'] = [{"term_id":3,"name":"COLUMNISTS","slug":"columnists","term_group":0,"term_taxonomy_id":3,"taxonomy":"category","description":"","parent":0,"count":1658,"filter":"raw","cat_ID":3,"category_count":1658,"category_description":"","cat_name":"COLUMNISTS","category_nicename":"columnists","category_parent":0}]; _mmunch['postTags'] = [{"term_id":6644,"name":"Black people in America","slug":"black-people-in-america","term_group":0,"term_taxonomy_id":6644,"taxonomy":"post_tag","description":"","parent":0,"count":3,"filter":"raw"},{"term_id":22870,"name":"George Floyd\u2019s death","slug":"george-floyds-death","term_group":0,"term_taxonomy_id":22870,"taxonomy":"post_tag","description":"","parent":0,"count":8,"filter":"raw"},{"term_id":23354,"name":"killing of Black people","slug":"killing-of-black-people","term_group":0,"term_taxonomy_id":23354,"taxonomy":"post_tag","description":"","parent":0,"count":2,"filter":"raw"},{"term_id":6804,"name":"POLICE","slug":"police","term_group":0,"term_taxonomy_id":6804,"taxonomy":"post_tag","description":"","parent":0,"count":5,"filter":"raw"},{"term_id":3710,"name":"Roger Caldwell","slug":"roger-caldwell","term_group":0,"term_taxonomy_id":3710,"taxonomy":"post_tag","description":"","parent":0,"count":17,"filter":"raw"}]; _mmunch['postAuthor'] = {"name":"FCEditor5","ID":23};</script><script data-cfasync="false" src="//a.mailmunch.co/app/v1/site.js" id="mailmunch-script" data-plugin="mc_mm" data-mailmunch-site-id="786149" async></script>
<!-- Google Tag Manager for WordPress by gtm4wp.com -->
<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[//]]>
</script>
<!-- End Google Tag Manager for WordPress by gtm4wp.com --><!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
        <script>
        window.tdb_globals = {"wpRestNonce":"d49cca936f","wpRestUrl":"https:\/\/flcourier.com\/wp-json\/","permalinkStructure":"\/%postname%\/","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};
    </script>
    			<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/flcourier.com\/wp-admin\/","wpRestNonce":"d49cca936f","wpRestUrl":"https:\/\/flcourier.com\/wp-json\/","permalinkStructure":"\/%postname%\/"};
			</script>
			<script type='application/javascript'>console.warn('PixelYourSite: no pixel configured.');</script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script>(adsbygoogle = window.adsbygoogle || []).push({"google_ad_client":"ca-pub-4158178132733447","enable_page_level_ads":true,"tag_partner":"site_kit"});</script>
<!-- JS generated by theme -->

<script>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</script>


<!-- Header style compiled by theme -->

<style>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</style>

<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-20957626-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-20957626-1');
</script>


<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://flcourier.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://flcourier.com/category/columnists/",
                    "name": "COLUMNISTS"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://flcourier.com/police-must-stop-killing-black-people-in-america/",
                    "name": "Police must stop killing Black people in America"                                
                }
            }    
        ]
    }
</script>
<!-- ## NXS/OG ## --><!-- ## NXSOGTAGS ## --><!-- ## NXS/OG ## -->

<!-- Button style compiled by theme -->

<style>
    .tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,
                .tds-button2 .tdm-btn-text,
                .tds-button2 i,
                .tds-button5:hover .tdm-btn-text,
                .tds-button5:hover i,
                .tds-button6 .tdm-btn-text,
                .tds-button6 i,
                .tdm_block_list .tdm-list-item i,
                .tdm_block_pricing .tdm-pricing-feature i,
                .tdm-social-item i {
                    color: #965f0c;
                }
                .tds-button1,
                .tds-button6:after,
                .tds-title2 .tdm-title-line:after,
                .tds-title3 .tdm-title-line:after,
                .tdm_block_pricing.tdm-pricing-featured:before,
                .tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,
                .tds-progress-bar1 .tdm-progress-bar:after,
                .tds-progress-bar2 .tdm-progress-bar:after,
                .tds-social3 .tdm-social-item {
                    background-color: #965f0c;
                }
                .tds-button2:before,
                .tds-button6:before,
                .tds-progress-bar3 .tdm-progress-bar:after {
                  border-color: #965f0c;
                }
                .tdm-btn-style1 {
					background-color: #965f0c;
				}
				.tdm-btn-style2:before {
				    border-color: #965f0c;
				}
				.tdm-btn-style2 {
				    color: #965f0c;
				}
				.tdm-btn-style3 {
				    -webkit-box-shadow: 0 2px 16px #965f0c;
                    -moz-box-shadow: 0 2px 16px #965f0c;
                    box-shadow: 0 2px 16px #965f0c;
				}
				.tdm-btn-style3:hover {
				    -webkit-box-shadow: 0 4px 26px #965f0c;
                    -moz-box-shadow: 0 4px 26px #965f0c;
                    box-shadow: 0 4px 26px #965f0c;
				}
</style>

<meta name="generator" content="WordPress Download Manager 3.1.23" />
	<style id="tdw-css-placeholder"></style>            <style>
                                @import url('https://fonts.googleapis.com/css?family=Rubik:400,500');
                


                .w3eden .fetfont,
                .w3eden .btn,
                .w3eden .btn.wpdm-front h3.title,
                .w3eden .wpdm-social-lock-box .IN-widget a span:last-child,
                .w3eden #xfilelist .panel-heading,
                .w3eden .wpdm-frontend-tabs a,
                .w3eden .alert:before,
                .w3eden .panel .panel-heading,
                .w3eden .discount-msg,
                .w3eden .panel.dashboard-panel h3,
                .w3eden #wpdm-dashboard-sidebar .list-group-item,
                .w3eden #package-description .wp-switch-editor,
                .w3eden .w3eden.author-dashbboard .nav.nav-tabs li a,
                .w3eden .wpdm_cart thead th,
                .w3eden #csp .list-group-item,
                .w3eden .modal-title {
                    font-family: Rubik, -apple-system, BlinkMacSystemFont, "Segoe UI", Roboto, Helvetica, Arial, sans-serif, "Apple Color Emoji", "Segoe UI Emoji", "Segoe UI Symbol";
                    text-transform: uppercase;
                    font-weight: 500;
                }
                .w3eden #csp .list-group-item{
                    text-transform: unset;
                }
            </style>
                    <style>

            :root{
                --color-primary: #4a8eff;
                --color-primary-rgb: 74, 142, 255;
                --color-primary-hover: #4a8eff;
                --color-primary-active: #4a8eff;
                --color-secondary: #4a8eff;
                --color-secondary-rgb: 74, 142, 255;
                --color-secondary-hover: #4a8eff;
                --color-secondary-active: #4a8eff;
                --color-success: #18ce0f;
                --color-success-rgb: 24, 206, 15;
                --color-success-hover: #4a8eff;
                --color-success-active: #4a8eff;
                --color-info: #2CA8FF;
                --color-info-rgb: 44, 168, 255;
                --color-info-hover: #2CA8FF;
                --color-info-active: #2CA8FF;
                --color-warning: #f29e0f;
                --color-warning-rgb: 242, 158, 15;
                --color-warning-hover: orange;
                --color-warning-active: orange;
                --color-danger: #ff5062;
                --color-danger-rgb: 255, 80, 98;
                --color-danger-hover: #ff5062;
                --color-danger-active: #ff5062;
                --color-green: #30b570;
                --color-blue: #0073ff;
                --color-purple: #8557D3;
                --color-red: #ff5062;
                --color-muted: rgba(69, 89, 122, 0.6);
                --wpdm-font: Rubik, -apple-system, BlinkMacSystemFont, "Segoe UI", Roboto, Helvetica, Arial, sans-serif, "Apple Color Emoji", "Segoe UI Emoji", "Segoe UI Symbol";
            }
            .wpdm-download-link.btn.btn-primary{
                border-radius: 4px;
            }


        </style>
        </head>

<body class="post-template-default single single-post postid-34206 single-format-standard td-standard-pack police-must-stop-killing-black-people-in-america global-block-template-1 td-local-news single_template_5 td-animation-stack-type0 td-boxed-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>

    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/flcourier/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/flcourier" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
                    <div class="td-menu-login-section">
                
    <div class="td-guest-wrap">
        <div class="td-menu-login"><a id="login-link-mob">Sign in</a></div>
    </div>
            </div>
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-main-menu-container"><ul id="menu-main-menu" class="td-mobile-main-menu"><li id="menu-item-68" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-68"><a href="https://flcourier.com/category/front-page/">FRONT PAGE</a></li>
<li id="menu-item-65" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65"><a href="https://flcourier.com/category/florida/">FLORIDA</a></li>
<li id="menu-item-70" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-70"><a href="https://flcourier.com/category/national/">NATIONAL</a></li>
<li id="menu-item-62" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62"><a href="https://flcourier.com/category/commentaries/">COMMENTARIES</a></li>
<li id="menu-item-202" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-202"><a href="https://flcourier.com/category/metro/">METRO</a></li>
<li id="menu-item-60" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-60"><a href="https://flcourier.com/category/business/">BUSINESS</a></li>
<li id="menu-item-63" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-63"><a href="https://flcourier.com/category/education/">EDUCATION</a></li>
<li id="menu-item-64" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64"><a href="https://flcourier.com/category/entertainment/">ENTERTAINMENT</a></li>
<li id="menu-item-302" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-302"><a href="https://flcourier.com/category/health/">HEALTH</a></li>
<li id="menu-item-67" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-67"><a href="https://flcourier.com/category/food/">FOOD</a></li>
<li id="menu-item-72" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-72"><a href="https://flcourier.com/category/technology/">TECHNOLOGY</a></li>
<li id="menu-item-66" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66"><a href="https://flcourier.com/category/floridas-finest/">FLORIDA&#8217;S FINEST</a></li>
<li id="menu-item-299" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-299"><a href="https://flcourier.com/category/sports/">SPORTS</a></li>
<li id="menu-item-71" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71"><a href="https://flcourier.com/category/politics/">POLITICS</a></li>
<li id="menu-item-69" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-69"><a href="https://flcourier.com/category/world/">WORLD</a></li>
<li id="menu-item-27449" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27449"><a href="https://flcourier.com/about-us/">ABOUT US</a></li>
<li id="menu-item-27452" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-27452"><a href="https://flcourier.com/our-sister-sites/">OUR SISTER SITES<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-27454" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27454"><a href="https://flcourier.com/our-sister-sites/daytona-times/">DAYTONA TIMES</a></li>
	<li id="menu-item-27453" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27453"><a href="https://flcourier.com/our-sister-sites/la-jefa-94-9fm-1070am/">LA JEFA 94.9FM &#038; 1070AM</a></li>
</ul>
</li>
<li id="menu-item-27455" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-27455"><a href="https://flcourier.com/tribute-to-our-founder/">TRIBUTE TO OUR FOUNDER<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-27458" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27458"><a href="https://flcourier.com/tribute-to-our-founder/the-life/">The Life</a></li>
	<li id="menu-item-27459" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27459"><a href="https://flcourier.com/tribute-to-our-founder/the-love/">The Love</a></li>
	<li id="menu-item-27456" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27456"><a href="https://flcourier.com/tribute-to-our-founder/the-family/">The Family</a></li>
	<li id="menu-item-27462" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27462"><a href="https://flcourier.com/tribute-to-our-founder/the-school/">The School</a></li>
	<li id="menu-item-27457" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27457"><a href="https://flcourier.com/tribute-to-our-founder/the-influences/">The Influences</a></li>
	<li id="menu-item-27460" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27460"><a href="https://flcourier.com/tribute-to-our-founder/the-mission/">The Mission</a></li>
	<li id="menu-item-27461" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27461"><a href="https://flcourier.com/tribute-to-our-founder/the-mission-accomplished-and-the-charge/">The Mission Accomplished and The Charge</a></li>
</ul>
</li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
            <div id="login-form-mobile" class="td-register-section">
            
            <div id="td-login-mob" class="td-login-animation td-login-hide-mob">
            	<!-- close button -->
	            <div class="td-login-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Sign in</div>
	                <!-- close button -->
		            <div class="td-mobile-close">
		                <a href="#"><i class="td-icon-close-mobile"></i></a>
		            </div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
	                <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
	                <div class="td-login-info-text">
	                <a href="#" id="forgot-pass-link-mob">Forgot your password?</a>
	                </div>
	                <div class="td-login-register-link">
	                
	                </div>
	                
	                

                </div>
            </div>

            
            
            
            
            <div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">
                <!-- close button -->
	            <div class="td-forgot-pass-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Password recovery</div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title">Recover your password</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
	                <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
                </div>
            </div>
        </div>
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search">
		<form method="get" class="td-search-form" action="https://flcourier.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>

    <div id="td-outer-wrap" class="td-theme-wrap">
    
        
            <div class="tdc-header-wrap ">

            <!--
Header style 2
-->


<div class="td-header-wrap td-header-style-2 ">
    
    <div class="td-header-top-menu-full td-container-wrap ">
        <div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	        <div class="td_data_time">
            <div >

                Sunday, May 2, 2021
            </div>
        </div>
    <ul class="top-header-menu td_ul_login"><li class="menu-item"><a class="td-login-modal-js menu-item" href="#login-form" data-effect="mpf-td-login-effect">Sign in / Join</a><span class="td-sp-ico-login td_sp_login_ico_style"></span></li></ul></div>
        <div class="td-header-sp-top-widget">
    
    </div>    </div>

<!-- LOGIN MODAL -->

                <div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
                    <div class="td-login-wrap">
                        <a href="#" class="td-back-button"><i class="td-icon-modal-back"></i></a>
                        <div id="td-login-div" class="td-login-form-div td-display-block">
                            <div class="td-login-panel-title">Sign in</div>
                            <div class="td-login-panel-descr">Welcome! Log into your account</div>
                            <div class="td_display_err"></div>
                            <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email" value="" required><label>your username</label></div>
	                        <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" required><label>your password</label></div>
                            <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login">
                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div>
                            
                            
                            
                            
                        </div>

                        

                         <div id="td-forgot-pass-div" class="td-login-form-div td-display-none">
                            <div class="td-login-panel-title">Password recovery</div>
                            <div class="td-login-panel-descr">Recover your password</div>
                            <div class="td_display_err"></div>
                            <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label>your email</label></div>
                            <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password">
                            <div class="td-login-info-text">A password will be e-mailed to you.</div>
                        </div>
                        
                        
                    </div>
                </div>
                        </div>
    </div>

    <div class="td-header-menu-wrap-full td-container-wrap ">
        
        <div class="td-header-menu-wrap td-header-gradient ">
            <div class="td-container td-header-row td-header-main-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-header">
        		<a class="td-mobile-logo td-sticky-mobile" href="https://flcourier.com/">
			<img class="td-retina-data" data-retina="https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/uploads/2017/08/fc_logo280x96-2.jpg" src="https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/uploads/2017/08/fc_logo140x48-2.jpg" alt="FLORIDA COURIER" title="Sharing Black LIfe, Statewide"/>
		</a>
			<a class="td-header-logo td-sticky-mobile" href="https://flcourier.com/">
			<img class="td-retina-data" data-retina="https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/uploads/2017/08/FClogo-544x180-2-300x99.jpg" src="https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/uploads/2017/08/fc_logo280x96-2.jpg" alt="FLORIDA COURIER" title="Sharing Black LIfe, Statewide"/>
		</a>
	    </div>
    <div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-normal-menu menu-item-68"><a href="https://flcourier.com/category/front-page/">FRONT PAGE</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-65"><a href="https://flcourier.com/category/florida/">FLORIDA</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-70"><a href="https://flcourier.com/category/national/">NATIONAL</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-62"><a href="https://flcourier.com/category/commentaries/">COMMENTARIES</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-202"><a href="https://flcourier.com/category/metro/">METRO</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-60"><a href="https://flcourier.com/category/business/">BUSINESS</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-63"><a href="https://flcourier.com/category/education/">EDUCATION</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-64"><a href="https://flcourier.com/category/entertainment/">ENTERTAINMENT</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-302"><a href="https://flcourier.com/category/health/">HEALTH</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-67"><a href="https://flcourier.com/category/food/">FOOD</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-72"><a href="https://flcourier.com/category/technology/">TECHNOLOGY</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-66"><a href="https://flcourier.com/category/floridas-finest/">FLORIDA&#8217;S FINEST</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-299"><a href="https://flcourier.com/category/sports/">SPORTS</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-71"><a href="https://flcourier.com/category/politics/">POLITICS</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-69"><a href="https://flcourier.com/category/world/">WORLD</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-27449"><a href="https://flcourier.com/about-us/">ABOUT US</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-27452"><a href="https://flcourier.com/our-sister-sites/">OUR SISTER SITES</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-27454"><a href="https://flcourier.com/our-sister-sites/daytona-times/">DAYTONA TIMES</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-27453"><a href="https://flcourier.com/our-sister-sites/la-jefa-94-9fm-1070am/">LA JEFA 94.9FM &#038; 1070AM</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-27455"><a href="https://flcourier.com/tribute-to-our-founder/">TRIBUTE TO OUR FOUNDER</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-27458"><a href="https://flcourier.com/tribute-to-our-founder/the-life/">The Life</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-27459"><a href="https://flcourier.com/tribute-to-our-founder/the-love/">The Love</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-27456"><a href="https://flcourier.com/tribute-to-our-founder/the-family/">The Family</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-27462"><a href="https://flcourier.com/tribute-to-our-founder/the-school/">The School</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-27457"><a href="https://flcourier.com/tribute-to-our-founder/the-influences/">The Influences</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-27460"><a href="https://flcourier.com/tribute-to-our-founder/the-mission/">The Mission</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-27461"><a href="https://flcourier.com/tribute-to-our-founder/the-mission-accomplished-and-the-charge/">The Mission Accomplished and The Charge</a></li>
</ul>
</li>
</ul></div></div>


    <div class="header-search-wrap">
        <div class="td-search-btns-wrap">
            <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            <a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
        </div>

        <div class="td-drop-down-search" aria-labelledby="td-header-search-button">
            <form method="get" class="td-search-form" action="https://flcourier.com/">
                <div role="search" class="td-head-form-search-wrap">
                    <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
                </div>
            </form>
            <div id="td-aj-search"></div>
        </div>
    </div>
            </div>
        </div>
    </div>

    <div class="td-banner-wrap-full td-container-wrap ">
        <div class="td-container td-header-row td-header-header">
            <div class="td-header-sp-logo">
                        <a class="td-main-logo" href="https://flcourier.com/">
            <img class="td-retina-data" data-retina="https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/uploads/2017/08/FClogo-544x180-2-300x99.jpg" src="https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/uploads/2017/08/fc_logo280x96-2.jpg" alt="FLORIDA COURIER" title="Sharing Black LIfe, Statewide"/>
            <span class="td-visual-hidden">Florida Courier</span>
        </a>
                </div>
                            <div class="td-header-sp-recs">
                    <div class="td-header-rec-wrap">
    <div class="td-a-rec td-a-rec-id-header  tdi_1_bbb td_block_template_1">
<style>
/* custom css */
.tdi_1_bbb.td-a-rec-img{
				    text-align: left;
				}.tdi_1_bbb.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }
</style><div class="td-all-devices">  <!-- Florida Courier 728x90 ATF [async] -->
<script type="text/javascript">if (!window.AdButler){(function(){var s = document.createElement("script"); s.async = true; s.type = "text/javascript";s.src = 'https://servedbyadbutler.com/app.js';var n = document.getElementsByTagName("script")[0]; n.parentNode.insertBefore(s, n);}());}</script>
<script type="text/javascript">
var AdButler = AdButler || {}; AdButler.ads = AdButler.ads || [];
var abkw = window.abkw || '';
var plc318608 = window.plc318608 || 0;
document.write('<'+'div id="placement_318608_'+plc318608+'"></'+'div>');
AdButler.ads.push({handler: function(opt){ AdButler.register(168170, 318608, [728,90], 'placement_318608_'+opt.place, opt); }, opt: { place: plc318608++, keywords: abkw, domain: 'servedbyadbutler.com', click:'CLICK_MACRO_PLACEHOLDER' }});
</script></div>
</div>
</div>                </div>
                    </div>
    </div>

</div>
            </div>

            
<div class="td-main-content-wrap td-container-wrap">

    <div class="td-container td-post-template-5 ">
        <div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://flcourier.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in COLUMNISTS" class="entry-crumb" href="https://flcourier.com/category/columnists/">COLUMNISTS</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Police must stop killing Black people in America</span></div></div>
            <div class="td-pb-row">
                                            <div class="td-pb-span8 td-main-content" role="main">
                                <div class="td-ss-main-content">
                                    
    <article id="post-34206" class="post-34206 post type-post status-publish format-standard has-post-thumbnail category-columnists tag-black-people-in-america tag-george-floyds-death tag-killing-of-black-people tag-police tag-roger-caldwell" itemscope itemtype="https://schema.org/Article">
        <div class="td-post-header">

            
            <header class="td-post-title">
                <h1 class="entry-title">Police must stop killing Black people in America</h1>

                

                <div class="td-module-meta-info">
                                        <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-04-30T07:49:48+00:00" >April 30, 2021</time></span>                                                        </div>

            </header>

        </div>

        

        <div class="td-post-content">
            <div class="td-a-rec td-a-rec-id-content_top  tdi_2_998 td_block_template_1">
<style>
/* custom css */
.tdi_2_998.td-a-rec-img{
				    text-align: left;
				}.tdi_2_998.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }
</style><span class="td-adspot-title">ADVERTISEMENT</span><!-- Florida Courier 728x90 ATF [async] -->
<script type="text/javascript">if (!window.AdButler){(function(){var s = document.createElement("script"); s.async = true; s.type = "text/javascript";s.src = 'https://servedbyadbutler.com/app.js';var n = document.getElementsByTagName("script")[0]; n.parentNode.insertBefore(s, n);}());}</script>
<script type="text/javascript">
var AdButler = AdButler || {}; AdButler.ads = AdButler.ads || [];
var abkw = window.abkw || '';
var plc318608 = window.plc318608 || 0;
document.write('<'+'div id="placement_318608_'+plc318608+'"></'+'div>');
AdButler.ads.push({handler: function(opt){ AdButler.register(168170, 318608, [728,90], 'placement_318608_'+opt.place, opt); }, opt: { place: plc318608++, keywords: abkw, domain: 'servedbyadbutler.com', click:'CLICK_MACRO_PLACEHOLDER' }});
</script></div><div class='mailmunch-forms-before-post' style='display: none !important;'></div><p><img loading="lazy" class="alignleft size-medium wp-image-19685" src="https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/uploads/2019/02/Roger-Caldwell-300x175.jpg" alt="" width="300" height="175" srcset="https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/uploads/2019/02/Roger-Caldwell-300x175.jpg 300w, https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/uploads/2019/02/Roger-Caldwell.jpg 580w" sizes="(max-width: 300px) 100vw, 300px" />America is at war with Black People, and people of color.</p>
<p>How could a credible Minneapolis police department put out a factual press release, which was a complete lie, and had no truth in it? “Man Dies after Medical Incident during Police Intervention,” says the Minneapolis police department concerning George Floyd’s death.</p>
<p>This is an indicator of what you can believe when you read or look at the news.</p>
<p>As long as the lie sounds good, it is assumed everyone will swallow the lie, and it’s okay. When the story includes a Black person, and police, it is rare for the police to lose.</p>
<p>This incident was done in the daytime, and the murder was executed with citizens taking photos, and videos.</p>
<p>If 17-year-old Darnella Frazier did not have the courage and tenacity to video the incident, the policeman Derek Chauvin could be free, and the truth would had been pushed under the rug.</p>
<p>When it comes to the credibility of any police department in the country, everyone is sprinkled with some corruption, and lies. Everyone will tell you that is how it is, and don’t get too excited with just one win.</p>
<h4><strong>We won one</strong></h4>
<p>“This week’s verdict provides a critical measure of accountability, there is so much more we must do to achieve true justice in this country.</p>
<p>Justice would mean George Floyd was alive today. It would mean Daunte Wright was also alive today. It would mean so many others were alive today.</p>
<p>And simply being alive is not enough, it would mean that we were breaking the grip of racism and white supremacy that prevents us from achieving true justice,” said Rahna Epting of Move On.</p>
<p>It is time to rejoice, and breathe a sigh of relief, because there was a conviction on all three counts. The protesters, all the demonstrating, the praying, the dreaming, the crying, the fighting, it all paid off.</p><div class='mailmunch-forms-in-post-middle' style='display: none !important;'></div>
<h4><strong>One of many</strong></h4>
<p>The police are still killing, in every Black community in America, but they saw Chauvin being led out of the courtroom in hand cups. Too many police are criminals and the question everyone keep asking in the Black community, “Why are there so many drugs in our community?”</p>
<p>The blue wall of silence is starting to crumble, because the police force is starting to reflect and look like the people in the community. When police in a trial tell the truth against another member of the force, something is starting to change.</p>
<p>But, after 24 hours of the verdict being read in the murder case against Chauvin, at least six Americans were shot by officers, and mostly Black.</p>
<p>There was a 16-year-old girl in Columbus, Ohio, an oft-arrested man in Escondido, California, a 42-year-old man in eastern, North Carolina, an unidentified man in San Antonio, another man killed in the same city within hours of the first, and finally a 31-year-old man in Massachusetts. It means the fight is not even close to being over.</p>
<h4><strong>It’s not over</strong></h4>
<p>It is very easy for the police around the country to say that they are doing their job and killing is part of the job. But when we compare the numbers of deaths of other police departments around the world, our violence and deaths are the most around the globe.</p>
<p>In the days, weeks, and months ahead, these new deaths will spark new cries for justice, and an urgent need for radical change.</p>
<p>This is a historic and visionary approach to start to resolve the violence and deaths police departments are having around the country. Killing of Black people and people of color must stop and end now.</p>
<p>May George Floyd and the hundreds of thousands of Black people who have died at the hands ofthe police, rest in peace.</p>
<p><em>Roger Caldwell, a community activist, author, journalist, radio host and CEO of On Point Media Group, lives in Orlando. Contact him at <a href="mailto:jet38@bellsouth.net">jet38@bellsouth.net</a>.&nbsp; </em></p>
<div class='mailmunch-forms-after-post' style='display: none !important;'></div><div class="td-a-rec td-a-rec-id-content_bottom  tdi_3_bb9 td_block_template_1">
<style>
/* custom css */
.tdi_3_bb9.td-a-rec-img{
				    text-align: left;
				}.tdi_3_bb9.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }
</style><span class="td-adspot-title">ADVERTISEMENT</span><ins class='dcmads' style='display:inline-block;width:728px;height:90px'
    data-dcm-placement='N46002.3768276FLORIDACOURIER/B25245327.292708619'
    data-dcm-rendering-mode='script'
    data-dcm-https-only
    data-dcm-gdpr-applies='gdpr=${GDPR}'
    data-dcm-gdpr-consent='gdpr_consent=${GDPR_CONSENT_755}'
    data-dcm-addtl-consent='addtl_consent=${ADDTL_CONSENT}'
    data-dcm-resettable-device-id=''
    data-dcm-app-id=''>
  <script src='https://www.googletagservices.com/dcm/dcmads.js'></script>
</ins></div>        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                            </div>

            <div class="td-post-sharing-bottom"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://flcourier.com/police-must-stop-killing-black-people-in-america/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:auto; height:21px; background-color:transparent;"></iframe></div></div>            <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://flcourier.com/serving-america-in-what-context/">Serving America in what context?</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="https://flcourier.com/i-love-disney-world-but-wokeness-is-ruining-the-experience/">I love Disney World, but wokeness is ruining the experience</a></div></div></div>            <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://flcourier.com/author/fceditor5/">FCEditor5</a></span></div>            <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="FCEditor5"></span><meta itemprop="datePublished" content="2021-04-30T07:49:48-05:00"><meta itemprop="dateModified" content="2021-04-30T07:49:48-05:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://flcourier.com/police-must-stop-killing-black-people-in-america/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/uploads/2017/08/fc_logo280x96-2.jpg"></span><meta itemprop="name" content="Florida Courier"></span><meta itemprop="headline " content="Police must stop killing Black people in America"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/uploads/2019/02/Roger-Caldwell.jpg?time=1619958089"><meta itemprop="width" content="580"><meta itemprop="height" content="339"></span>        </footer>

    </article> <!-- /.post -->

    <div class="td_block_wrap td_block_related_posts tdi_4_95e td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="tdi_4_95e" ><script>var block_tdi_4_95e = new tdBlock();
block_tdi_4_95e.id = "tdi_4_95e";
block_tdi_4_95e.atts = '{"limit":6,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"tdi_4_95e","td_column_number":3,"live_filter_cur_post_id":34206,"live_filter_cur_post_author":"23","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_4_95e","tdc_css_class_style":"tdi_4_95e_rand_style"}';
block_tdi_4_95e.td_column_number = "3";
block_tdi_4_95e.block_type = "td_block_related_posts";
block_tdi_4_95e.post_count = "6";
block_tdi_4_95e.found_posts = "1657";
block_tdi_4_95e.header_color = "";
block_tdi_4_95e.ajax_pagination_infinite_stop = "";
block_tdi_4_95e.max_num_pages = "277";
tdBlocksArray.push(block_tdi_4_95e);
</script><h4 class="td-related-title td-block-title"><a id="tdi_5_e8b" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_4_95e" href="#">RELATED ARTICLES</a><a id="tdi_6_9d9" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_4_95e" href="#">MORE FROM AUTHOR</a></h4><div id=tdi_4_95e class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://flcourier.com/i-love-disney-world-but-wokeness-is-ruining-the-experience/" rel="bookmark" class="td-image-wrap" title="I love Disney World, but wokeness is ruining the experience"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="I love Disney World, but wokeness is ruining the experience" data-type="image_tag" data-img-url="https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/uploads/2021/04/Jonathan-Vanboskerck-218x150.png" data-img-retina-url="https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/uploads/2021/04/Jonathan-Vanboskerck-436x300.png" width="218" height="150" /></a></div>                <a href="https://flcourier.com/category/columnists/" class="td-post-category">COLUMNISTS</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://flcourier.com/i-love-disney-world-but-wokeness-is-ruining-the-experience/" rel="bookmark" title="I love Disney World, but wokeness is ruining the experience">I love Disney World, but wokeness is ruining the experience</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://flcourier.com/serving-america-in-what-context/" rel="bookmark" class="td-image-wrap" title="Serving America in what context?"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Serving America in what context?" data-type="image_tag" data-img-url="https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/uploads/2020/10/oscar-218x150.png" data-img-retina-url="https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/uploads/2020/10/oscar-436x300.png" width="218" height="150" /></a></div>                <a href="https://flcourier.com/category/columnists/" class="td-post-category">COLUMNISTS</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://flcourier.com/serving-america-in-what-context/" rel="bookmark" title="Serving America in what context?">Serving America in what context?</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://flcourier.com/its-time-for-black-community-security-forces/" rel="bookmark" class="td-image-wrap" title="It’s time for Black community security forces"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="It’s time for Black community security forces" data-type="image_tag" data-img-url="https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/uploads/2019/07/LUCIUS-GANTT-218x150.jpg" data-img-retina-url="https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/uploads/2019/07/LUCIUS-GANTT-e1593185465303.jpg?time=1619958089" width="218" height="150" /></a></div>                <a href="https://flcourier.com/category/columnists/" class="td-post-category">COLUMNISTS</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://flcourier.com/its-time-for-black-community-security-forces/" rel="bookmark" title="It’s time for Black community security forces">It’s time for Black community security forces</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid-->

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://flcourier.com/its-time-for-b-cus-board-chair-to-walk-away/" rel="bookmark" class="td-image-wrap" title="It’s time for B-CU’s board chair to walk away"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="Chairman Belvin Perry" title="It’s time for B-CU’s board chair to walk away" data-type="image_tag" data-img-url="https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/uploads/2021/04/Chairman-Belvin-Perry-218x150.jpg" data-img-retina-url="https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/uploads/2021/04/Chairman-Belvin-Perry-436x300.jpg" width="218" height="150" /></a></div>                <a href="https://flcourier.com/category/columnists/" class="td-post-category">COLUMNISTS</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://flcourier.com/its-time-for-b-cus-board-chair-to-walk-away/" rel="bookmark" title="It’s time for B-CU’s board chair to walk away">It’s time for B-CU’s board chair to walk away</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://flcourier.com/a-verdict-that-must-change-america/" rel="bookmark" class="td-image-wrap" title="A verdict that must change America"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="TRICUNE Editorial bOARD" title="A verdict that must change America" data-type="image_tag" data-img-url="https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/uploads/2021/04/TRICUNE-Editorial-bOARD-218x150.png" data-img-retina-url="https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/uploads/2021/04/TRICUNE-Editorial-bOARD-436x300.png" width="218" height="150" /></a></div>                <a href="https://flcourier.com/category/columnists/" class="td-post-category">COLUMNISTS</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://flcourier.com/a-verdict-that-must-change-america/" rel="bookmark" title="A verdict that must change America">A verdict that must change America</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://flcourier.com/we-cant-stop-here/" rel="bookmark" class="td-image-wrap" title="We can’t stop here"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="Hamil R. Harris" title="We can’t stop here" data-type="image_tag" data-img-url="https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/uploads/2021/04/Hamil-R.-218x150.png" data-img-retina-url="https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/uploads/2021/04/Hamil-R.-436x300.png" width="218" height="150" /></a></div>                <a href="https://flcourier.com/category/columnists/" class="td-post-category">COLUMNISTS</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://flcourier.com/we-cant-stop-here/" rel="bookmark" title="We can’t stop here">We can’t stop here</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_4_95e" data-td_block_id="tdi_4_95e"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-tdi_4_95e" data-td_block_id="tdi_4_95e"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->
    <div class="comments" id="comments">
        	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">LEAVE A REPLY <small><a rel="nofollow" id="cancel-comment-reply-link" href="/police-must-stop-killing-black-people-in-america/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://flcourier.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><div class="clearfix"></div>
				<div class="comment-form-input-wrap td-form-comment">
					<textarea placeholder="Comment:" id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea>
					<div class="td-warning-comment">Please enter your comment!</div>
				</div>
		        <div class="comment-form-input-wrap td-form-author">
			            <input class="" id="author" name="author" placeholder="Name:*" type="text" value="" size="30"  aria-required='true' />
			            <div class="td-warning-author">Please enter your name here</div>
			         </div>
<div class="comment-form-input-wrap td-form-email">
			            <input class="" id="email" name="email" placeholder="Email:*" type="text" value="" size="30"  aria-required='true' />
			            <div class="td-warning-email-error">You have entered an incorrect email address!</div>
			            <div class="td-warning-email">Please enter your email address here</div>
			         </div>
<div class="comment-form-input-wrap td-form-url">
			            <input class="" id="url" name="url" placeholder="Website:" type="text" value="" size="30" />
                     </div>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<!-- Mailchimp for WordPress v4.8.3 - https://www.mc4wp.com/ --><input type="hidden" name="_mc4wp_subscribe_wp-comment-form" value="0" /><p class=" mc4wp-checkbox mc4wp-checkbox-wp-comment-form" ><label><input type="checkbox" name="_mc4wp_subscribe_wp-comment-form" value="1"  /><span>Sign me up for the newsletter!</span></label></p><!-- / Mailchimp for WordPress --><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='34206' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="d9026471a6" /></p><input type="hidden" id="ak_js" name="ak_js" value="6"/><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form>	</div><!-- #respond -->
	    </div> <!-- /.content -->
                                    </div>
                            </div>
                            <div class="td-pb-span4 td-main-sidebar" role="complementary">
                                <div class="td-ss-main-sidebar">
                                    <aside class="td_block_template_1 widget widget_archive"><h4 class="block-title"><span>florida courier archives</span></h4>		<label class="screen-reader-text" for="archives-dropdown-5">florida courier archives</label>
		<select id="archives-dropdown-5" name="archive-dropdown">
			
			<option value="">Select Month</option>
				<option value='https://flcourier.com/2021/05/'> May 2021 &nbsp;(3)</option>
	<option value='https://flcourier.com/2021/04/'> April 2021 &nbsp;(105)</option>
	<option value='https://flcourier.com/2021/03/'> March 2021 &nbsp;(84)</option>
	<option value='https://flcourier.com/2021/02/'> February 2021 &nbsp;(108)</option>
	<option value='https://flcourier.com/2021/01/'> January 2021 &nbsp;(120)</option>
	<option value='https://flcourier.com/2020/12/'> December 2020 &nbsp;(77)</option>
	<option value='https://flcourier.com/2020/11/'> November 2020 &nbsp;(82)</option>
	<option value='https://flcourier.com/2020/10/'> October 2020 &nbsp;(89)</option>
	<option value='https://flcourier.com/2020/09/'> September 2020 &nbsp;(95)</option>
	<option value='https://flcourier.com/2020/08/'> August 2020 &nbsp;(98)</option>
	<option value='https://flcourier.com/2020/07/'> July 2020 &nbsp;(73)</option>
	<option value='https://flcourier.com/2020/06/'> June 2020 &nbsp;(82)</option>
	<option value='https://flcourier.com/2020/05/'> May 2020 &nbsp;(110)</option>
	<option value='https://flcourier.com/2020/04/'> April 2020 &nbsp;(102)</option>
	<option value='https://flcourier.com/2020/03/'> March 2020 &nbsp;(133)</option>
	<option value='https://flcourier.com/2020/02/'> February 2020 &nbsp;(140)</option>
	<option value='https://flcourier.com/2020/01/'> January 2020 &nbsp;(118)</option>
	<option value='https://flcourier.com/2019/12/'> December 2019 &nbsp;(92)</option>
	<option value='https://flcourier.com/2019/11/'> November 2019 &nbsp;(79)</option>
	<option value='https://flcourier.com/2019/10/'> October 2019 &nbsp;(151)</option>
	<option value='https://flcourier.com/2019/09/'> September 2019 &nbsp;(175)</option>
	<option value='https://flcourier.com/2019/08/'> August 2019 &nbsp;(167)</option>
	<option value='https://flcourier.com/2019/07/'> July 2019 &nbsp;(192)</option>
	<option value='https://flcourier.com/2019/06/'> June 2019 &nbsp;(168)</option>
	<option value='https://flcourier.com/2019/05/'> May 2019 &nbsp;(158)</option>
	<option value='https://flcourier.com/2019/04/'> April 2019 &nbsp;(170)</option>
	<option value='https://flcourier.com/2019/03/'> March 2019 &nbsp;(159)</option>
	<option value='https://flcourier.com/2019/02/'> February 2019 &nbsp;(108)</option>
	<option value='https://flcourier.com/2019/01/'> January 2019 &nbsp;(69)</option>
	<option value='https://flcourier.com/2018/11/'> November 2018 &nbsp;(1)</option>
	<option value='https://flcourier.com/2018/10/'> October 2018 &nbsp;(3)</option>
	<option value='https://flcourier.com/2018/09/'> September 2018 &nbsp;(1)</option>
	<option value='https://flcourier.com/2018/04/'> April 2018 &nbsp;(17)</option>
	<option value='https://flcourier.com/2018/03/'> March 2018 &nbsp;(121)</option>
	<option value='https://flcourier.com/2018/02/'> February 2018 &nbsp;(81)</option>
	<option value='https://flcourier.com/2018/01/'> January 2018 &nbsp;(89)</option>
	<option value='https://flcourier.com/2017/12/'> December 2017 &nbsp;(107)</option>
	<option value='https://flcourier.com/2017/11/'> November 2017 &nbsp;(86)</option>
	<option value='https://flcourier.com/2017/10/'> October 2017 &nbsp;(60)</option>
	<option value='https://flcourier.com/2017/09/'> September 2017 &nbsp;(95)</option>
	<option value='https://flcourier.com/2017/08/'> August 2017 &nbsp;(131)</option>
	<option value='https://flcourier.com/2017/07/'> July 2017 &nbsp;(107)</option>
	<option value='https://flcourier.com/2017/06/'> June 2017 &nbsp;(132)</option>
	<option value='https://flcourier.com/2017/05/'> May 2017 &nbsp;(109)</option>
	<option value='https://flcourier.com/2017/04/'> April 2017 &nbsp;(104)</option>
	<option value='https://flcourier.com/2017/03/'> March 2017 &nbsp;(126)</option>
	<option value='https://flcourier.com/2017/02/'> February 2017 &nbsp;(84)</option>
	<option value='https://flcourier.com/2017/01/'> January 2017 &nbsp;(96)</option>
	<option value='https://flcourier.com/2016/12/'> December 2016 &nbsp;(114)</option>
	<option value='https://flcourier.com/2016/11/'> November 2016 &nbsp;(86)</option>
	<option value='https://flcourier.com/2016/10/'> October 2016 &nbsp;(93)</option>
	<option value='https://flcourier.com/2016/09/'> September 2016 &nbsp;(100)</option>
	<option value='https://flcourier.com/2016/08/'> August 2016 &nbsp;(97)</option>
	<option value='https://flcourier.com/2016/07/'> July 2016 &nbsp;(113)</option>
	<option value='https://flcourier.com/2016/06/'> June 2016 &nbsp;(89)</option>
	<option value='https://flcourier.com/2016/05/'> May 2016 &nbsp;(95)</option>
	<option value='https://flcourier.com/2016/04/'> April 2016 &nbsp;(101)</option>
	<option value='https://flcourier.com/2016/03/'> March 2016 &nbsp;(124)</option>
	<option value='https://flcourier.com/2016/02/'> February 2016 &nbsp;(98)</option>
	<option value='https://flcourier.com/2016/01/'> January 2016 &nbsp;(104)</option>
	<option value='https://flcourier.com/2015/12/'> December 2015 &nbsp;(116)</option>
	<option value='https://flcourier.com/2015/11/'> November 2015 &nbsp;(93)</option>
	<option value='https://flcourier.com/2015/10/'> October 2015 &nbsp;(113)</option>
	<option value='https://flcourier.com/2015/09/'> September 2015 &nbsp;(94)</option>
	<option value='https://flcourier.com/2015/08/'> August 2015 &nbsp;(94)</option>
	<option value='https://flcourier.com/2015/07/'> July 2015 &nbsp;(117)</option>
	<option value='https://flcourier.com/2015/06/'> June 2015 &nbsp;(97)</option>
	<option value='https://flcourier.com/2015/05/'> May 2015 &nbsp;(130)</option>
	<option value='https://flcourier.com/2015/04/'> April 2015 &nbsp;(108)</option>
	<option value='https://flcourier.com/2015/03/'> March 2015 &nbsp;(98)</option>

		</select>

<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-5" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>
			</aside>                                </div>
                            </div>
                                    </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->

<!-- Instagram -->




	<!-- Footer -->
	<div class="td-footer-wrapper td-footer-container td-container-wrap td-footer-template-4 ">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
                <div class="td-a-rec td-a-rec-id-footer_top  tdi_7_989 td_block_template_1">
<style>
/* custom css */
.tdi_7_989.td-a-rec-img{
				    text-align: left;
				}.tdi_7_989.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }
</style><!-- Florida Courier 728x90 BTF [async] -->
<script type="text/javascript">if (!window.AdButler){(function(){var s = document.createElement("script"); s.async = true; s.type = "text/javascript";s.src = 'https://servedbyadbutler.com/app.js';var n = document.getElementsByTagName("script")[0]; n.parentNode.insertBefore(s, n);}());}</script>
<script type="text/javascript">
var AdButler = AdButler || {}; AdButler.ads = AdButler.ads || [];
var abkw = window.abkw || '';
var plc318610 = window.plc318610 || 0;
document.write('<'+'div id="placement_318610_'+plc318610+'"></'+'div>');
AdButler.ads.push({handler: function(opt){ AdButler.register(168170, 318610, [728,90], 'placement_318610_'+opt.place, opt); }, opt: { place: plc318610++, keywords: abkw, domain: 'servedbyadbutler.com', click:'CLICK_MACRO_PLACEHOLDER' }});
</script></div>		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span12">
                <div class="td-footer-info"><div class="footer-logo-wrap"><a href="https://flcourier.com/"><img src="https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/uploads/2015/03/FClogo-www970px-e1445307246565.jpg" alt="FLORIDA COURIER" title="Sharing Black Life, Statewide"/></a></div><div class="footer-text-wrap">Your credible, reliable resource of news and information affecting African-American communities across the state of Florida, USA.<div class="footer-email-wrap">Contact us: <a href="mailto:news@flcourier.com">news@flcourier.com</a></div></div><div class="footer-social-wrap td-social-style-2">
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/flcourier/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/flcourier" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div></div>            </div>
        </div>
    </div>
</div>
	<!-- Sub Footer -->
	

</div><!--close td-outer-wrap-->



<!-- Google Tag Manager (noscript) -->

    <!--

        Theme: Newspaper by tagDiv.com 2019
        Version: 10.2 (rara)
        Deploy mode: deploy
        
        uid: 608e9bd95e4f3
    -->

    <script type='text/javascript' src='https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-includes/js/jquery/jquery.form.min.js?ver=4.2.1&#038;time=1619958089' id='jquery-form-js'></script>
<script type='text/javascript' src='https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-includes/js/underscore.min.js?ver=1.8.3&#038;time=1619958089' id='underscore-js'></script>
<script type='text/javascript' src='https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=c8cba5620a72d5b299fa8f62aeca6adfx&#038;time=1619958089' id='tdb_js_posts_autoload-js'></script>
<script type='text/javascript' src='https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=10.2&#038;time=1619958089' id='td-site-min-js'></script>
<script type='text/javascript' src='https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-includes/js/comment-reply.min.js?ver=598b6385a0d101819a78886948270e2e&#038;time=1619958089' id='comment-reply-js'></script>
<script type='text/javascript' src='https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=c8cba5620a72d5b299fa8f62aeca6adfx&#038;time=1619958089' id='tdb_js_files_for_front-js'></script>
<script type='text/javascript' src='https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-includes/js/wp-embed.min.js?ver=598b6385a0d101819a78886948270e2e&#038;time=1619958089' id='wp-embed-js'></script>
<script async="async" type='text/javascript' src='https://secureservercdn.net/198.71.233.65/7p3.923.myftpupload.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.9&#038;time=1619958089' id='akismet-form-js'></script>

<!-- JS generated by theme -->

<script>
    
</script>


</body>
</html>