<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>NNPA elects Houston Forward Times publisher as chair &ndash; Florida Courier</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="http://flcourier.com/xmlrpc.php" />
    <meta property="og:image" content="http://flcourier.com/wp-content/uploads/2019/07/FC-NNPA-leaders.jpg" />
<!-- This site is optimized with the Yoast SEO plugin v11.5 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Karen Carter Richards, the publisher of the Houston Forward Times, has been elected as chair of the National Newspapers Publishers Association (NNPA),"/>
<link rel="canonical" href="http://flcourier.com/nnpa-elects-houston-forward-times-publisher-as-chair/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="NNPA elects Houston Forward Times publisher as chair &ndash; Florida Courier" />
<meta property="og:description" content="Karen Carter Richards, the publisher of the Houston Forward Times, has been elected as chair of the National Newspapers Publishers Association (NNPA)," />
<meta property="og:url" content="http://flcourier.com/nnpa-elects-houston-forward-times-publisher-as-chair/" />
<meta property="og:site_name" content="Florida Courier" />
<meta property="article:publisher" content="https://www.facebook.com/flcourier/" />
<meta property="article:tag" content="79TH YEAR FOR NNPA" />
<meta property="article:tag" content="African-American owned newspapers" />
<meta property="article:tag" content="Black Press in America" />
<meta property="article:tag" content="Dorothy Leavell" />
<meta property="article:tag" content="Houston Forward Times" />
<meta property="article:tag" content="Karen Carter Richards" />
<meta property="article:tag" content="National Newspapers Publishers Association" />
<meta property="article:tag" content="NNPA" />
<meta property="article:tag" content="NNPA elects" />
<meta property="article:tag" content="NNPA Legacy Awards" />
<meta property="article:tag" content="NNPA’s Publisher of the Year Award" />
<meta property="article:tag" content="Richards" />
<meta property="article:section" content="NATIONAL" />
<meta property="article:published_time" content="2019-07-02T05:53:32+00:00" />
<meta property="article:modified_time" content="2019-07-02T05:54:11+00:00" />
<meta property="og:updated_time" content="2019-07-02T05:54:11+00:00" />
<meta property="og:image" content="http://flcourier.com/wp-content/uploads/2019/07/FC-NNPA-leaders.jpg" />
<meta property="og:image:width" content="1102" />
<meta property="og:image:height" content="735" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Karen Carter Richards, the publisher of the Houston Forward Times, has been elected as chair of the National Newspapers Publishers Association (NNPA)," />
<meta name="twitter:title" content="NNPA elects Houston Forward Times publisher as chair &ndash; Florida Courier" />
<meta name="twitter:site" content="@flcourier" />
<meta name="twitter:image" content="http://flcourier.com/wp-content/uploads/2019/07/FC-NNPA-leaders.jpg" />
<meta name="twitter:creator" content="@flcourier" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"http://flcourier.com/#organization","name":"Florida Courier","url":"http://flcourier.com/","sameAs":["https://www.facebook.com/flcourier/","https://twitter.com/flcourier"],"logo":{"@type":"ImageObject","@id":"http://flcourier.com/#logo","url":"http://flcourier.com/wp-content/uploads/2017/08/fc_logo140x48-2.jpg","width":140,"height":48,"caption":"Florida Courier"},"image":{"@id":"http://flcourier.com/#logo"}},{"@type":"WebSite","@id":"http://flcourier.com/#website","url":"http://flcourier.com/","name":"Florida Courier","publisher":{"@id":"http://flcourier.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"http://flcourier.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"http://flcourier.com/nnpa-elects-houston-forward-times-publisher-as-chair/#primaryimage","url":"http://flcourier.com/wp-content/uploads/2019/07/FC-NNPA-leaders.jpg","width":1102,"height":735},{"@type":"WebPage","@id":"http://flcourier.com/nnpa-elects-houston-forward-times-publisher-as-chair/#webpage","url":"http://flcourier.com/nnpa-elects-houston-forward-times-publisher-as-chair/","inLanguage":"en-US","name":"NNPA elects Houston Forward Times publisher as chair &ndash; Florida Courier","isPartOf":{"@id":"http://flcourier.com/#website"},"primaryImageOfPage":{"@id":"http://flcourier.com/nnpa-elects-houston-forward-times-publisher-as-chair/#primaryimage"},"datePublished":"2019-07-02T05:53:32+00:00","dateModified":"2019-07-02T05:54:11+00:00","description":"Karen Carter Richards, the publisher of the Houston Forward Times, has been elected as chair of the National Newspapers Publishers Association (NNPA),"},{"@type":"Article","@id":"http://flcourier.com/nnpa-elects-houston-forward-times-publisher-as-chair/#article","isPartOf":{"@id":"http://flcourier.com/nnpa-elects-houston-forward-times-publisher-as-chair/#webpage"},"author":{"@id":"http://flcourier.com/author/fceditor3/#author"},"headline":"NNPA elects Houston Forward Times publisher as chair","datePublished":"2019-07-02T05:53:32+00:00","dateModified":"2019-07-02T05:54:11+00:00","commentCount":0,"mainEntityOfPage":{"@id":"http://flcourier.com/nnpa-elects-houston-forward-times-publisher-as-chair/#webpage"},"publisher":{"@id":"http://flcourier.com/#organization"},"image":{"@id":"http://flcourier.com/nnpa-elects-houston-forward-times-publisher-as-chair/#primaryimage"},"keywords":"79TH YEAR FOR NNPA,African-American owned newspapers,Black Press in America,Dorothy Leavell,Houston Forward Times,Karen Carter Richards,National Newspapers Publishers Association,NNPA,NNPA elects,NNPA Legacy Awards,NNPA\u2019s Publisher of the Year Award,Richards","articleSection":"NATIONAL,NEWS"},{"@type":["Person"],"@id":"http://flcourier.com/author/fceditor3/#author","name":"Vijayakumar B","image":{"@type":"ImageObject","@id":"http://flcourier.com/#authorlogo","url":"http://0.gravatar.com/avatar/c1144c347e5a899931b745561510c6fe?s=96&d=mm&r=g","caption":"Vijayakumar B"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//use.fontawesome.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Florida Courier &raquo; Feed" href="http://flcourier.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Florida Courier &raquo; Comments Feed" href="http://flcourier.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Florida Courier &raquo; NNPA elects Houston Forward Times publisher as chair Comments Feed" href="http://flcourier.com/nnpa-elects-houston-forward-times-publisher-as-chair/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/flcourier.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=9094be56be2cfe055c3ff006f0032250"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='fontawesome_v4_shim_style-css'  href='https://use.fontawesome.com/releases/v5.3.1/css/v4-shims.css?ver=9094be56be2cfe055c3ff006f0032250' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='https://use.fontawesome.com/releases/v5.3.1/css/all.css?ver=9094be56be2cfe055c3ff006f0032250' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='http://flcourier.com/wp-includes/css/dist/block-library/style.min.css?ver=9094be56be2cfe055c3ff006f0032250' type='text/css' media='all' />
<link rel='stylesheet' id='photocrati-image_protection-css-css'  href='http://flcourier.com/wp-content/plugins/nextgen-gallery-pro/modules/image_protection/static/custom.css?ver=9094be56be2cfe055c3ff006f0032250' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='http://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900&#038;ver=8.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='http://flcourier.com/wp-content/themes/Newspaper/style.css?ver=8.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css'  href='http://flcourier.com/wp-content/themes/Newspaper/includes/demos/local_news/demo_style.css?ver=8.1' type='text/css' media='all' />
<script type='text/javascript' src='https://use.fontawesome.com/releases/v5.3.1/js/v4-shims.js?ver=5.3.1'></script>
<script type='text/javascript' defer integrity="sha384-kW+oWsYx3YpxvjtZjFXqazFpA7UP/MbiY4jvs+RWZo2+N94PFZ36T6TFkc9O3qoB" crossorigin="anonymous" data-auto-replace-svg="false" data-keep-original-source="false" data-search-pseudo-elements src='https://use.fontawesome.com/releases/v5.3.1/js/all.js?ver=5.3.1'></script>
<script type='text/javascript' src='http://flcourier.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='http://flcourier.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var photocrati_ajax = {"url":"http:\/\/flcourier.com\/?photocrati_ajax=1","wp_home_url":"http:\/\/flcourier.com","wp_site_url":"http:\/\/flcourier.com","wp_root_url":"http:\/\/flcourier.com","wp_plugins_url":"http:\/\/flcourier.com\/wp-content\/plugins","wp_content_url":"http:\/\/flcourier.com\/wp-content","wp_includes_url":"http:\/\/flcourier.com\/wp-includes\/","ngg_param_slug":"nggallery"};
/* ]]> */
</script>
<script type='text/javascript' src='http://flcourier.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/ajax/static/ajax.min.js?ver=3.2.4'></script>
<script type='text/javascript' src='http://flcourier.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript' src='http://flcourier.com/wp-includes/js/backbone.min.js?ver=1.2.3'></script>
<script type='text/javascript' src='http://flcourier.com/wp-content/plugins/nextgen-gallery-pro/modules/ecommerce/static/sprintf.js?ver=9094be56be2cfe055c3ff006f0032250'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var Ngg_Pro_Cart_Settings = {"currency_format":"<i class='fa fa-usd'><\/i>%.2f","checkout_url":"http:\/\/flcourier.com\/shopping-cart\/","use_cookies":"true"};
/* ]]> */
</script>
<script type='text/javascript' src='http://flcourier.com/wp-content/plugins/nextgen-gallery-pro/modules/ecommerce/static/cart.js?ver=9094be56be2cfe055c3ff006f0032250'></script>
<script type='text/javascript' src='http://flcourier.com/wp-content/plugins/nextgen-gallery-pro/modules/image_protection/static/pressure.js?ver=9094be56be2cfe055c3ff006f0032250'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var photocrati_image_protection_global = {"enabled":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://flcourier.com/wp-content/plugins/nextgen-gallery-pro/modules/image_protection/static/custom.js?ver=9094be56be2cfe055c3ff006f0032250'></script>
<link rel='https://api.w.org/' href='http://flcourier.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://flcourier.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://flcourier.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='http://flcourier.com/?p=23135' />
<link rel="alternate" type="application/json+oembed" href="http://flcourier.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fflcourier.com%2Fnnpa-elects-houston-forward-times-publisher-as-chair%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://flcourier.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fflcourier.com%2Fnnpa-elects-houston-forward-times-publisher-as-chair%2F&#038;format=xml" />
<!-- <meta name="NextGEN" version="3.2.4" /> -->
<script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//flcourier.com/?wordfence_lh=1&hid=F0C2D73E4D2F8052154DCC5EB9EC4C8F');
</script>	<style id="tdw-css-placeholder"></style>			<script>
				window.tdwGlobal = {"adminUrl":"http:\/\/flcourier.com\/wp-admin\/","wpRestNonce":"2a539be766","wpRestUrl":"http:\/\/flcourier.com\/wp-json\/","permalinkStructure":"\/%postname%\/"};
			</script>
			<!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    
<!-- JS generated by theme -->

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

            if( -1 !== navigator.userAgent.indexOf('IEMobile') ){
                htmlTag.className += ' td-md-is-iemobile';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var tds_login_sing_in_widget="show";
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_animation_stack_effect="type0";
var tds_animation_stack=true;
var td_animation_stack_specific_selectors=".entry-thumb, img";
var td_animation_stack_general_selectors=".td-animation-stack img, .td-animation-stack .entry-thumb, .post img";
var tds_general_modal_image="yes";
var td_ajax_url="http:\/\/flcourier.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=8.1";
var td_get_template_directory_uri="http:\/\/flcourier.com\/wp-content\/themes\/Newspaper";
var tds_snap_menu="smart_snap_always";
var tds_logo_on_sticky="show";
var tds_header_style="";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#965f0c";
var tds_smart_sidebar="enabled";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>


<!-- Header style compiled by theme -->

<style>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</style>

<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-20957626-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-20957626-1');
</script><script type="application/ld+json">
                        {
                            "@context": "http://schema.org",
                            "@type": "BreadcrumbList",
                            "itemListElement": [{
                            "@type": "ListItem",
                            "position": 1,
                                "item": {
                                "@type": "WebSite",
                                "@id": "http://flcourier.com/",
                                "name": "Home"                                               
                            }
                        },{
                            "@type": "ListItem",
                            "position": 2,
                                "item": {
                                "@type": "WebPage",
                                "@id": "http://flcourier.com/category/national/",
                                "name": "NATIONAL"
                            }
                        },{
                            "@type": "ListItem",
                            "position": 3,
                                "item": {
                                "@type": "WebPage",
                                "@id": "http://flcourier.com/nnpa-elects-houston-forward-times-publisher-as-chair/",
                                "name": "NNPA elects Houston Forward Times publisher as chair"                                
                            }
                        }    ]
                        }
                       </script><!-- ## NXS/OG ## --><!-- ## NXSOGTAGS ## --><!-- ## NXS/OG ## -->
</head>

<body class="post-template-default single single-post postid-23135 single-format-standard nnpa-elects-houston-forward-times-publisher-as-chair global-block-template-1 td-local-news single_template_5 td-animation-stack-type0 td-boxed-layout" itemscope="itemscope" itemtype="http://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/flcourier/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/flcourier" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
                    <div class="td-menu-login-section">
                
    <div class="td-guest-wrap">
        <div class="td-menu-avatar"><div class="td-avatar-container"><img alt='' src='http://2.gravatar.com/avatar/?s=80&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/?s=160&#038;d=mm&#038;r=g 2x' class='avatar avatar-80 photo avatar-default' height='80' width='80' /></div></div>
        <div class="td-menu-login"><a id="login-link-mob">Sign in</a></div>
    </div>
            </div>
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-main-menu-container"><ul id="menu-main-menu" class="td-mobile-main-menu"><li id="menu-item-68" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-68"><a href="http://flcourier.com/category/front-page/">FRONT PAGE</a></li>
<li id="menu-item-65" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65"><a href="http://flcourier.com/category/florida/">FLORIDA</a></li>
<li id="menu-item-70" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-70"><a href="http://flcourier.com/category/national/">NATIONAL</a></li>
<li id="menu-item-62" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62"><a href="http://flcourier.com/category/commentaries/">COMMENTARIES</a></li>
<li id="menu-item-202" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-202"><a href="http://flcourier.com/category/metro/">METRO</a></li>
<li id="menu-item-60" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-60"><a href="http://flcourier.com/category/business/">BUSINESS</a></li>
<li id="menu-item-63" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-63"><a href="http://flcourier.com/category/education/">EDUCATION</a></li>
<li id="menu-item-64" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64"><a href="http://flcourier.com/category/entertainment/">ENTERTAINMENT</a></li>
<li id="menu-item-302" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-302"><a href="http://flcourier.com/category/health/">HEALTH</a></li>
<li id="menu-item-67" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-67"><a href="http://flcourier.com/category/food/">FOOD</a></li>
<li id="menu-item-72" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-72"><a href="http://flcourier.com/category/technology/">TECHNOLOGY</a></li>
<li id="menu-item-66" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66"><a href="http://flcourier.com/category/floridas-finest/">FLORIDA&#8217;S FINEST</a></li>
<li id="menu-item-299" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-299"><a href="http://flcourier.com/category/sports/">SPORTS</a></li>
<li id="menu-item-71" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71"><a href="http://flcourier.com/category/politics/">POLITICS</a></li>
<li id="menu-item-69" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-69"><a href="http://flcourier.com/category/world/">WORLD</a></li>
<li id="menu-item-15736" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15736"><a href="http://flcourier.com/miami-broward-one-carnival-2017/">MIAMI BROWARD CARNIVAL 2017</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
            <div id="login-form-mobile" class="td-register-section">
            
            <div id="td-login-mob" class="td-login-animation td-login-hide-mob">
            	<!-- close button -->
	            <div class="td-login-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Sign in</div>
	                <!-- close button -->
		            <div class="td-mobile-close">
		                <a href="#"><i class="td-icon-close-mobile"></i></a>
		            </div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
	                <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
	                <div class="td-login-info-text"><a href="#" id="forgot-pass-link-mob">Forgot your password?</a></div>
                </div>
            </div>

            

            <div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">
                <!-- close button -->
	            <div class="td-forgot-pass-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Password recovery</div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title">Recover your password</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
	                <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
                </div>
            </div>
        </div>
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="http://flcourier.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>    
    
    <div id="td-outer-wrap" class="td-theme-wrap">
    
        <!--
Header style 1
-->
<div class="td-header-wrap td-header-style-1">

    <div class="td-header-top-menu-full td-container-wrap ">
        <div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	        <div class="td_data_time">
            <div >

                Tuesday, July 2, 2019
            </div>
        </div>
    <ul class="top-header-menu td_ul_login"><li class="menu-item"><a class="td-login-modal-js menu-item" href="#login-form" data-effect="mpf-td-login-effect">Sign in / Join</a><span class="td-sp-ico-login td_sp_login_ico_style"></span></li></ul><div class="menu-top-container"><ul id="menu-secondary-menu" class="top-header-menu"><li id="menu-item-301" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-301"><a href="http://flcourier.com/community-calendar/">COMMUNITY CALENDAR</a></li>
<li id="menu-item-36" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-36"><a href="http://flcourier.com/about-us/">ABOUT US</a></li>
<li id="menu-item-39" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-39"><a href="http://flcourier.com/tribute-to-our-founder/">TRIBUTE TO OUR FOUNDER</a>
<ul class="sub-menu">
	<li id="menu-item-46" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-46"><a href="http://flcourier.com/tribute-to-our-founder/the-life/">The Life</a></li>
	<li id="menu-item-45" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-45"><a href="http://flcourier.com/tribute-to-our-founder/the-love/">The Love</a></li>
	<li id="menu-item-43" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-43"><a href="http://flcourier.com/tribute-to-our-founder/the-school/">The School</a></li>
	<li id="menu-item-42" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-42"><a href="http://flcourier.com/tribute-to-our-founder/the-influences/">The Influences</a></li>
	<li id="menu-item-44" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-44"><a href="http://flcourier.com/tribute-to-our-founder/the-family/">The Family</a></li>
	<li id="menu-item-41" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-41"><a href="http://flcourier.com/tribute-to-our-founder/the-mission/">The Mission</a></li>
	<li id="menu-item-40" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-40"><a href="http://flcourier.com/tribute-to-our-founder/the-mission-accomplished-and-the-charge/">The Mission Accomplished and The Charge</a></li>
</ul>
</li>
<li id="menu-item-52" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-52"><a href="http://flcourier.com/our-sister-sites/">OUR SISTER SITES</a>
<ul class="sub-menu">
	<li id="menu-item-227" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-227"><a href="http://www.daytonatimes.com">DAYTONA TIMES</a></li>
	<li id="menu-item-228" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-228"><a href="http://www.lajefa949.com">LA JEFA 94.9FM &#038; 1070AM</a></li>
</ul>
</li>
<li id="menu-item-37" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-37"><a href="http://flcourier.com/contact-us/">CONTACT US</a></li>
<li id="menu-item-18869" class="nextgen-menu-cart-icon-auto menu-item menu-item-type-post_type menu-item-object-page nextgen-menu-item-cart td-menu-item td-normal-menu menu-item-18869"><a href="http://flcourier.com/shopping-cart/"><i class="fa fa-shopping-cart nextgen-menu-cart-icon nextgen-menu-cart-icon-icon_and_total_with_items" style="display:none"></i> <span class="nextgen-menu-cart-placeholder"></span></a></li>
</ul></div></div>
        <div class="td-header-sp-top-widget">
    
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/flcourier/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/flcourier" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div>
    </div>

<!-- LOGIN MODAL -->

                <div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
                    <div class="td-login-wrap">
                        <a href="#" class="td-back-button"><i class="td-icon-modal-back"></i></a>
                        <div id="td-login-div" class="td-login-form-div td-display-block">
                            <div class="td-login-panel-title">Sign in</div>
                            <div class="td-login-panel-descr">Welcome! Log into your account</div>
                            <div class="td_display_err"></div>
                            <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email" value="" required><label>your username</label></div>
	                        <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" required><label>your password</label></div>
                            <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login">
                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div>
                            
                        </div>

                        

                         <div id="td-forgot-pass-div" class="td-login-form-div td-display-none">
                            <div class="td-login-panel-title">Password recovery</div>
                            <div class="td-login-panel-descr">Recover your password</div>
                            <div class="td_display_err"></div>
                            <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label>your email</label></div>
                            <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password">
                            <div class="td-login-info-text">A password will be e-mailed to you.</div>
                        </div>
                    </div>
                </div>
                        </div>
    </div>

    <div class="td-banner-wrap-full td-logo-wrap-full td-container-wrap ">
        <div class="td-container td-header-row td-header-header">
            <div class="td-header-sp-logo">
                        <a class="td-main-logo" href="http://flcourier.com/">
            <img class="td-retina-data" data-retina="http://flcourier.com/wp-content/uploads/2017/08/FClogo-544x180-2-300x99.jpg" src="http://flcourier.com/wp-content/uploads/2017/08/fc_logo280x96-2.jpg" alt="FLORIDA COURIER" title="Sharing Black LIfe, Statewide"/>
            <span class="td-visual-hidden">Florida Courier</span>
        </a>
                </div>
            <div class="td-header-sp-recs">
                <div class="td-header-rec-wrap">
    <div class="td-a-rec td-a-rec-id-header  td_uid_1_5d1af1a5a492d_rand td_block_template_1"><!-- Florida Courier Wells Fargo Prepare to Prosper 728x90 ATF [async] -->
<script type="text/javascript">if (!window.AdButler){(function(){var s = document.createElement("script"); s.async = true; s.type = "text/javascript";s.src = 'https://servedbyadbutler.com/app.js';var n = document.getElementsByTagName("script")[0]; n.parentNode.insertBefore(s, n);}());}</script>
<script type="text/javascript">
var AdButler = AdButler || {}; AdButler.ads = AdButler.ads || [];
var abkw = window.abkw || '';
var plc318608 = window.plc318608 || 0;
document.write('<'+'div id="placement_318608_'+plc318608+'"></'+'div>');
AdButler.ads.push({handler: function(opt){ AdButler.register(168170, 318608, [728,90], 'placement_318608_'+opt.place, opt); }, opt: { place: plc318608++, keywords: abkw, domain: 'servedbyadbutler.com', click:'CLICK_MACRO_PLACEHOLDER' }});
</script></div>
</div>            </div>
        </div>
    </div>

    <div class="td-header-menu-wrap-full td-container-wrap ">
        <div class="td-header-menu-wrap td-header-gradient">
            <div class="td-container td-header-row td-header-main-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-header">
        		<a class="td-mobile-logo td-sticky-mobile" href="http://flcourier.com/">
			<img class="td-retina-data" data-retina="http://flcourier.com/wp-content/uploads/2017/08/fc_logo280x96-2.jpg" src="http://flcourier.com/wp-content/uploads/2017/08/fc_logo140x48-2.jpg" alt="FLORIDA COURIER" title="Sharing Black LIfe, Statewide"/>
		</a>
			<a class="td-header-logo td-sticky-mobile" href="http://flcourier.com/">
			<img class="td-retina-data" data-retina="http://flcourier.com/wp-content/uploads/2017/08/FClogo-544x180-2-300x99.jpg" src="http://flcourier.com/wp-content/uploads/2017/08/fc_logo280x96-2.jpg" alt="FLORIDA COURIER" title="Sharing Black LIfe, Statewide"/>
		</a>
	    </div>
    <div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-normal-menu menu-item-68"><a href="http://flcourier.com/category/front-page/">FRONT PAGE</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-65"><a href="http://flcourier.com/category/florida/">FLORIDA</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-70"><a href="http://flcourier.com/category/national/">NATIONAL</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-62"><a href="http://flcourier.com/category/commentaries/">COMMENTARIES</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-202"><a href="http://flcourier.com/category/metro/">METRO</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-60"><a href="http://flcourier.com/category/business/">BUSINESS</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-63"><a href="http://flcourier.com/category/education/">EDUCATION</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-64"><a href="http://flcourier.com/category/entertainment/">ENTERTAINMENT</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-302"><a href="http://flcourier.com/category/health/">HEALTH</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-67"><a href="http://flcourier.com/category/food/">FOOD</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-72"><a href="http://flcourier.com/category/technology/">TECHNOLOGY</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-66"><a href="http://flcourier.com/category/floridas-finest/">FLORIDA&#8217;S FINEST</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-299"><a href="http://flcourier.com/category/sports/">SPORTS</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-71"><a href="http://flcourier.com/category/politics/">POLITICS</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-69"><a href="http://flcourier.com/category/world/">WORLD</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-15736"><a href="http://flcourier.com/miami-broward-one-carnival-2017/">MIAMI BROWARD CARNIVAL 2017</a></li>
</ul></div></div>


<div class="td-search-wrapper">
    <div id="td-top-search">
        <!-- Search -->
        <div class="header-search-wrap">
            <div class="dropdown header-search">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>
        </div>
    </div>
</div>

<div class="header-search-wrap">
	<div class="dropdown header-search">
		<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
			<form method="get" class="td-search-form" action="http://flcourier.com/">
				<div role="search" class="td-head-form-search-wrap">
					<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
				</div>
			</form>
			<div id="td-aj-search"></div>
		</div>
	</div>
</div>            </div>
        </div>
    </div>

</div><div class="td-main-content-wrap td-container-wrap">

    <div class="td-container td-post-template-5 ">
        <div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="http://flcourier.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in NATIONAL" class="entry-crumb" href="http://flcourier.com/category/national/">NATIONAL</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">NNPA elects Houston Forward Times publisher as chair</span></div></div>
            <div class="td-pb-row">
                                            <div class="td-pb-span8 td-main-content" role="main">
                                <div class="td-ss-main-content">
                                    
    <article id="post-23135" class="post-23135 post type-post status-publish format-standard has-post-thumbnail hentry category-national category-news tag-79th-year-for-nnpa tag-african-american-owned-newspapers tag-black-press-in-america tag-dorothy-leavell tag-houston-forward-times tag-karen-carter-richards tag-national-newspapers-publishers-association tag-nnpa tag-nnpa-elects tag-nnpa-legacy-awards tag-nnpas-publisher-of-the-year-award tag-richards" itemscope itemtype="http://schema.org/Article">
        <div class="td-post-header">

            
            <header class="td-post-title">
                <h1 class="entry-title">NNPA elects Houston Forward Times publisher as chair</h1>

                

                <div class="td-module-meta-info">
                                        <span class="td-post-date td-post-date-no-dot"><time class="entry-date updated td-module-date" datetime="2019-07-02T00:53:32+00:00" >July 2, 2019</time></span>                                                        </div>

            </header>

        </div>

        

        <div class="td-post-content">
            
<figure class="wp-block-image"><img src="http://flcourier.com/wp-content/uploads/2019/07/FC-NNPA-leaders-1024x683.jpg" alt="Richards" class="wp-image-23136" srcset="http://flcourier.com/wp-content/uploads/2019/07/FC-NNPA-leaders-1024x683.jpg 1024w, http://flcourier.com/wp-content/uploads/2019/07/FC-NNPA-leaders-300x200.jpg 300w, http://flcourier.com/wp-content/uploads/2019/07/FC-NNPA-leaders-768x512.jpg 768w, http://flcourier.com/wp-content/uploads/2019/07/FC-NNPA-leaders-696x464.jpg 696w, http://flcourier.com/wp-content/uploads/2019/07/FC-NNPA-leaders-1068x712.jpg 1068w, http://flcourier.com/wp-content/uploads/2019/07/FC-NNPA-leaders-630x420.jpg 630w, http://flcourier.com/wp-content/uploads/2019/07/FC-NNPA-leaders.jpg 1102w" sizes="(max-width: 1024px) 100vw, 1024px" /><figcaption> <strong><em>MARK MAHONEY</em></strong><em>/DREAM IN COLOR PHOTOGRAPHY/NNPA<br></em> Dr. Benjamin F. Chavis, Jr., (left), president and CEO of NNPA, congratulates Karen Carter Richards, the newly elected chair. </figcaption></figure>



<p>BY <strong>STACY M. BROWN </strong><br><em>NNPA NEWSWIRE</em></p>



<p>Karen Carter Richards, the publisher of the Houston Forward Times, has been elected as chair of the National Newspapers Publishers Association (NNPA), the trade organization that represents African American-owned newspapers and media companies throughout the country.</p>



<p>Richards, who in 2018 won the NNPA’s Publisher of the Year Award, succeeds Dorothy Leavell, publisher of the Chicago and Gary Crusader Newspapers.</p>



<p>“We did it!” Richards exclaimed during an NNPA Legacy Awards presentation at the Cincinnati Westin Hotel on June 28.</p>



<p>The organization also selected a new first- and second- vice chair, secretary, treasurer and at-large board members.</p>



<h4>79TH YEAR FOR NNPA</h4>



<p>The NNPA, which is celebrating its 79th year and 192 years of the Black Press in America, held its annual convention in the Queen City with Cincinnati Herald and Dayton Defender Publisher Jan Michele Kearney and Walter L. White, vice president of Sesh Communications hosting the weeklong event.</p>



<p>“I just want to thank my family for all of their support,” said Richards, a second-generation publisher who has enjoyed a long and distinguished career in journalism.<br>
Her father, Julius P. Carter, founded the Houston Forward Times in 1960 after recognizing a need for a newspaper that was committed to covering issues and personalities routinely ignored by mainstream media.</p>



<p>After Julius Carter’s death, the legendary Lenora “Doll” Carter assumed responsibility for the Forward Times with Karen Carter Richards working alongside her.</p>



<h4>‘A NEW VISION’</h4>



<p>Richards said she understands that being the chair comes with a lot of responsibilities and work.</p>



<p>After a fierce campaign, Richards said she will work to move the storied association forward, help to continue to provide Black America with critical news and information, and bridge any divides that might exist between members.</p>



<p>“I will win your trust,” Richards said. </p>



<p>“This is a new vision and I’m excited about serving. We are the Black Press, the Original Black Press and I’m so happy to serve and be the new chair of the NNPA.”</p>



<p>The Houston native said the importance of the Black Press should never be lost on anyone.</p>



<p>“We are the voice, the true voice of our people. We have recorded our history for 192 years like no other media could ever do,” she said. </p>



<p>“We have recorded many stories…our celebrations, our injustices and those hidden, treasured stories that came from our communities that we have always found value in. Let’s do this.”</p>
        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                            </div>

            <div class="td-post-sharing td-post-sharing-bottom td-with-like"><span class="td-post-share-title">SHARE</span>
            <div class="td-default-sharing">
	            <a class="td-social-sharing-buttons td-social-facebook" href="https://www.facebook.com/sharer.php?u=http%3A%2F%2Fflcourier.com%2Fnnpa-elects-houston-forward-times-publisher-as-chair%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-facebook"></i><div class="td-social-but-text">Facebook</div></a>
	            <a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=NNPA+elects+Houston+Forward+Times+publisher+as+chair&url=http%3A%2F%2Fflcourier.com%2Fnnpa-elects-houston-forward-times-publisher-as-chair%2F&via=flcourier"><i class="td-icon-twitter"></i><div class="td-social-but-text">Twitter</div></a>
	            <a class="td-social-sharing-buttons td-social-google" href="https://plus.google.com/share?url=http://flcourier.com/nnpa-elects-houston-forward-times-publisher-as-chair/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-googleplus"></i></a>
	            <a class="td-social-sharing-buttons td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=http://flcourier.com/nnpa-elects-houston-forward-times-publisher-as-chair/&amp;media=http://flcourier.com/wp-content/uploads/2019/07/FC-NNPA-leaders.jpg&description=Karen Carter Richards, the publisher of the Houston Forward Times, has been elected as chair of the National Newspapers Publishers Association (NNPA)," onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-pinterest"></i></a>
	            <a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=NNPA+elects+Houston+Forward+Times+publisher+as+chair%20-%20http%3A%2F%2Fflcourier.com%2Fnnpa-elects-houston-forward-times-publisher-as-chair%2F" ><i class="td-icon-whatsapp"></i></a>
            </div><div class="td-classic-sharing"><ul><li class="td-classic-facebook"><iframe frameBorder="0" src="http://www.facebook.com/plugins/like.php?href=http://flcourier.com/nnpa-elects-houston-forward-times-publisher-as-chair/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></li><li class="td-classic-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="http://flcourier.com/nnpa-elects-houston-forward-times-publisher-as-chair/" data-text="NNPA elects Houston Forward Times publisher as chair" data-via="" data-lang="en">tweet</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></li></ul></div></div>            <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="http://flcourier.com/suicide-rate-in-nation-increased-33-from-1999-to-2017/">Suicide rate in nation increased 33% from 1999 to 2017</a></div></div><div class="td-next-prev-separator"></div></div>            <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="http://flcourier.com/author/fceditor3/">Vijayakumar B</a></span></div>            <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Vijayakumar B"></span><meta itemprop="datePublished" content="2019-07-02T00:53:32+00:00"><meta itemprop="dateModified" content="2019-07-02T00:54:11-05:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://flcourier.com/nnpa-elects-houston-forward-times-publisher-as-chair/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://flcourier.com/wp-content/uploads/2017/08/fc_logo280x96-2.jpg"></span><meta itemprop="name" content="Florida Courier"></span><meta itemprop="headline " content="NNPA elects Houston Forward Times publisher as chair"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://flcourier.com/wp-content/uploads/2019/07/FC-NNPA-leaders.jpg"><meta itemprop="width" content="1102"><meta itemprop="height" content="735"></span>        </footer>

    </article> <!-- /.post -->

    <div class="td_block_wrap td_block_related_posts td_uid_3_5d1af1a5b140f_rand td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_3_5d1af1a5b140f" ><script>var block_td_uid_3_5d1af1a5b140f = new tdBlock();
block_td_uid_3_5d1af1a5b140f.id = "td_uid_3_5d1af1a5b140f";
block_td_uid_3_5d1af1a5b140f.atts = '{"limit":6,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_custom_related","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_3_5d1af1a5b140f_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_3_5d1af1a5b140f_rand","tdc_css_class_style":"td_uid_3_5d1af1a5b140f_rand_style","live_filter":"cur_post_same_categories","live_filter_cur_post_id":23135,"live_filter_cur_post_author":"11","block_template_id":""}';
block_td_uid_3_5d1af1a5b140f.td_column_number = "3";
block_td_uid_3_5d1af1a5b140f.block_type = "td_block_related_posts";
block_td_uid_3_5d1af1a5b140f.post_count = "6";
block_td_uid_3_5d1af1a5b140f.found_posts = "2131";
block_td_uid_3_5d1af1a5b140f.header_color = "";
block_td_uid_3_5d1af1a5b140f.ajax_pagination_infinite_stop = "";
block_td_uid_3_5d1af1a5b140f.max_num_pages = "356";
tdBlocksArray.push(block_td_uid_3_5d1af1a5b140f);
</script><h4 class="td-related-title td-block-title"><a id="td_uid_4_5d1af1a5b8456" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_3_5d1af1a5b140f" href="#">RELATED ARTICLES</a><a id="td_uid_5_5d1af1a5b84f7" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_3_5d1af1a5b140f" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_3_5d1af1a5b140f class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://flcourier.com/suicide-rate-in-nation-increased-33-from-1999-to-2017/" rel="bookmark" title="Suicide rate in nation increased 33% from 1999 to 2017"><img width="218" height="150" class="entry-thumb" src="http://flcourier.com/wp-content/uploads/2019/07/National-Suicide-Prevention-Lifeline-218x150.jpg" srcset="http://flcourier.com/wp-content/uploads/2019/07/National-Suicide-Prevention-Lifeline-218x150.jpg 218w, http://flcourier.com/wp-content/uploads/2019/07/National-Suicide-Prevention-Lifeline-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Suicide rate in nation increased 33% from 1999 to 2017"/></a></div>                <a href="http://flcourier.com/category/health/" class="td-post-category">HEALTH</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://flcourier.com/suicide-rate-in-nation-increased-33-from-1999-to-2017/" rel="bookmark" title="Suicide rate in nation increased 33% from 1999 to 2017">Suicide rate in nation increased 33% from 1999 to 2017</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://flcourier.com/trump-falsely-claims-obama-began-migrant-family-separations/" rel="bookmark" title="Trump falsely claims Obama began migrant family separations"><img width="218" height="150" class="entry-thumb" src="http://flcourier.com/wp-content/uploads/2019/07/Lirio-Funes-218x150.jpg" srcset="http://flcourier.com/wp-content/uploads/2019/07/Lirio-Funes-218x150.jpg 218w, http://flcourier.com/wp-content/uploads/2019/07/Lirio-Funes-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Trump falsely claims Obama began migrant family separations"/></a></div>                <a href="http://flcourier.com/category/national/" class="td-post-category">NATIONAL</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://flcourier.com/trump-falsely-claims-obama-began-migrant-family-separations/" rel="bookmark" title="Trump falsely claims Obama began migrant family separations">Trump falsely claims Obama began migrant family separations</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://flcourier.com/comments-show-democrats-are-anti-jewish/" rel="bookmark" title="Comments show Democrats are anti-Jewish"><img width="218" height="150" class="entry-thumb" src="http://flcourier.com/wp-content/uploads/2019/01/Clarence-V-Mckee-218x150.jpg" srcset="http://flcourier.com/wp-content/uploads/2019/01/Clarence-V-Mckee-218x150.jpg 218w, http://flcourier.com/wp-content/uploads/2019/01/Clarence-V-Mckee-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Comments show Democrats are anti-Jewish"/></a></div>                <a href="http://flcourier.com/category/columnists/" class="td-post-category">COLUMNISTS</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://flcourier.com/comments-show-democrats-are-anti-jewish/" rel="bookmark" title="Comments show Democrats are anti-Jewish">Comments show Democrats are anti-Jewish</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid-->

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://flcourier.com/americas-challenge-is-racial-healing-transformation/" rel="bookmark" title="America’s challenge is racial healing, transformation"><img width="218" height="150" class="entry-thumb" src="http://flcourier.com/wp-content/uploads/2019/07/Dr-Gail-C-Christopher-218x150.jpg" srcset="http://flcourier.com/wp-content/uploads/2019/07/Dr-Gail-C-Christopher-218x150.jpg 218w, http://flcourier.com/wp-content/uploads/2019/07/Dr-Gail-C-Christopher-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="America’s challenge is racial healing, transformation"/></a></div>                <a href="http://flcourier.com/category/columnists/" class="td-post-category">COLUMNISTS</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://flcourier.com/americas-challenge-is-racial-healing-transformation/" rel="bookmark" title="America’s challenge is racial healing, transformation">America’s challenge is racial healing, transformation</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://flcourier.com/americas-rulers-want-austerity-to-continue/" rel="bookmark" title="America’s rulers want austerity to continue"><img width="214" height="110" class="entry-thumb" src="http://flcourier.com/wp-content/uploads/2015/03/01-glenford02.jpg" alt="" title="America’s rulers want austerity to continue"/></a></div>                <a href="http://flcourier.com/category/columnists/" class="td-post-category">COLUMNISTS</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://flcourier.com/americas-rulers-want-austerity-to-continue/" rel="bookmark" title="America’s rulers want austerity to continue">America’s rulers want austerity to continue</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://flcourier.com/who-makes-the-best-ranch-dressing/" rel="bookmark" title="Who makes the best ranch dressing?"><img width="218" height="150" class="entry-thumb" src="http://flcourier.com/wp-content/uploads/2019/07/carrot-sticks-218x150.jpg" srcset="http://flcourier.com/wp-content/uploads/2019/07/carrot-sticks-218x150.jpg 218w, http://flcourier.com/wp-content/uploads/2019/07/carrot-sticks-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Who makes the best ranch dressing?"/></a></div>                <a href="http://flcourier.com/category/food/" class="td-post-category">FOOD</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://flcourier.com/who-makes-the-best-ranch-dressing/" rel="bookmark" title="Who makes the best ranch dressing?">Who makes the best ranch dressing?</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_3_5d1af1a5b140f" data-td_block_id="td_uid_3_5d1af1a5b140f"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_3_5d1af1a5b140f" data-td_block_id="td_uid_3_5d1af1a5b140f"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->
	<div class="comments" id="comments">
        	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">LEAVE A REPLY <small><a rel="nofollow" id="cancel-comment-reply-link" href="/nnpa-elects-houston-forward-times-publisher-as-chair/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="http://flcourier.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<div class="clearfix"></div>
				<div class="comment-form-input-wrap td-form-comment">
					<textarea placeholder="Comment:" id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea>
					<div class="td-warning-comment">Please enter your comment!</div>
				</div>
		        <div class="comment-form-input-wrap td-form-author">
			            <input class="" id="author" name="author" placeholder="Name:*" type="text" value="" size="30"  aria-required='true' />
			            <div class="td-warning-author">Please enter your name here</div>
			         </div>
<div class="comment-form-input-wrap td-form-email">
			            <input class="" id="email" name="email" placeholder="Email:*" type="text" value="" size="30"  aria-required='true' />
			            <div class="td-warning-email-error">You have entered an incorrect email address!</div>
			            <div class="td-warning-email">Please enter your email address here</div>
			         </div>
<div class="comment-form-input-wrap td-form-url">
			            <input class="" id="url" name="url" placeholder="Website:" type="text" value="" size="30" />
                     </div>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='23135' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="ba0870c924" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="158"/></p>			</form>
			</div><!-- #respond -->
	    </div> <!-- /.content -->
                                </div>
                            </div>
                            <div class="td-pb-span4 td-main-sidebar" role="complementary">
                                <div class="td-ss-main-sidebar">
                                    <div class="td-a-rec td-a-rec-id-custom_ad_2  td_uid_6_5d1af1a5c5eca_rand td_block_template_1"><div class="td-all-devices">
    <a href="https://moffitt.org/"><img src="http://flcourier.com/wp-content/uploads/2019/04/Moffitt-copy2.jpeg" alt="" /></a></div>


</div><aside class="td_block_template_1 widget widget_archive"><h4 class="block-title"><span>florida courier archives</span></h4>		<ul>
				<li><a href='http://flcourier.com/2019/07/'>July 2019</a>&nbsp;(14)</li>
	<li><a href='http://flcourier.com/2019/06/'>June 2019</a>&nbsp;(168)</li>
	<li><a href='http://flcourier.com/2019/05/'>May 2019</a>&nbsp;(158)</li>
	<li><a href='http://flcourier.com/2019/04/'>April 2019</a>&nbsp;(170)</li>
	<li><a href='http://flcourier.com/2019/03/'>March 2019</a>&nbsp;(159)</li>
	<li><a href='http://flcourier.com/2019/02/'>February 2019</a>&nbsp;(108)</li>
	<li><a href='http://flcourier.com/2019/01/'>January 2019</a>&nbsp;(69)</li>
	<li><a href='http://flcourier.com/2018/11/'>November 2018</a>&nbsp;(1)</li>
	<li><a href='http://flcourier.com/2018/10/'>October 2018</a>&nbsp;(3)</li>
	<li><a href='http://flcourier.com/2018/09/'>September 2018</a>&nbsp;(1)</li>
	<li><a href='http://flcourier.com/2018/04/'>April 2018</a>&nbsp;(17)</li>
	<li><a href='http://flcourier.com/2018/03/'>March 2018</a>&nbsp;(121)</li>
	<li><a href='http://flcourier.com/2018/02/'>February 2018</a>&nbsp;(81)</li>
	<li><a href='http://flcourier.com/2018/01/'>January 2018</a>&nbsp;(89)</li>
	<li><a href='http://flcourier.com/2017/12/'>December 2017</a>&nbsp;(107)</li>
	<li><a href='http://flcourier.com/2017/11/'>November 2017</a>&nbsp;(86)</li>
	<li><a href='http://flcourier.com/2017/10/'>October 2017</a>&nbsp;(60)</li>
	<li><a href='http://flcourier.com/2017/09/'>September 2017</a>&nbsp;(95)</li>
	<li><a href='http://flcourier.com/2017/08/'>August 2017</a>&nbsp;(131)</li>
	<li><a href='http://flcourier.com/2017/07/'>July 2017</a>&nbsp;(107)</li>
	<li><a href='http://flcourier.com/2017/06/'>June 2017</a>&nbsp;(132)</li>
	<li><a href='http://flcourier.com/2017/05/'>May 2017</a>&nbsp;(109)</li>
	<li><a href='http://flcourier.com/2017/04/'>April 2017</a>&nbsp;(104)</li>
	<li><a href='http://flcourier.com/2017/03/'>March 2017</a>&nbsp;(126)</li>
	<li><a href='http://flcourier.com/2017/02/'>February 2017</a>&nbsp;(84)</li>
	<li><a href='http://flcourier.com/2017/01/'>January 2017</a>&nbsp;(96)</li>
	<li><a href='http://flcourier.com/2016/12/'>December 2016</a>&nbsp;(114)</li>
	<li><a href='http://flcourier.com/2016/11/'>November 2016</a>&nbsp;(86)</li>
	<li><a href='http://flcourier.com/2016/10/'>October 2016</a>&nbsp;(93)</li>
	<li><a href='http://flcourier.com/2016/09/'>September 2016</a>&nbsp;(100)</li>
	<li><a href='http://flcourier.com/2016/08/'>August 2016</a>&nbsp;(97)</li>
	<li><a href='http://flcourier.com/2016/07/'>July 2016</a>&nbsp;(113)</li>
	<li><a href='http://flcourier.com/2016/06/'>June 2016</a>&nbsp;(89)</li>
	<li><a href='http://flcourier.com/2016/05/'>May 2016</a>&nbsp;(95)</li>
	<li><a href='http://flcourier.com/2016/04/'>April 2016</a>&nbsp;(101)</li>
	<li><a href='http://flcourier.com/2016/03/'>March 2016</a>&nbsp;(124)</li>
	<li><a href='http://flcourier.com/2016/02/'>February 2016</a>&nbsp;(98)</li>
	<li><a href='http://flcourier.com/2016/01/'>January 2016</a>&nbsp;(104)</li>
	<li><a href='http://flcourier.com/2015/12/'>December 2015</a>&nbsp;(116)</li>
	<li><a href='http://flcourier.com/2015/11/'>November 2015</a>&nbsp;(93)</li>
	<li><a href='http://flcourier.com/2015/10/'>October 2015</a>&nbsp;(113)</li>
	<li><a href='http://flcourier.com/2015/09/'>September 2015</a>&nbsp;(94)</li>
	<li><a href='http://flcourier.com/2015/08/'>August 2015</a>&nbsp;(94)</li>
	<li><a href='http://flcourier.com/2015/07/'>July 2015</a>&nbsp;(117)</li>
	<li><a href='http://flcourier.com/2015/06/'>June 2015</a>&nbsp;(97)</li>
	<li><a href='http://flcourier.com/2015/05/'>May 2015</a>&nbsp;(130)</li>
	<li><a href='http://flcourier.com/2015/04/'>April 2015</a>&nbsp;(108)</li>
	<li><a href='http://flcourier.com/2015/03/'>March 2015</a>&nbsp;(98)</li>
		</ul>
			</aside><div class="td_block_wrap td_block_social_counter td_block_widget td_uid_7_5d1af1a5c98d0_rand td-social-style1 td-pb-border-top td_block_template_1"><div class="td-block-title-wrap"><h4 class="block-title"><span class="td-pulldown-size">Follow us</span></h4></div><div class="td-social-list"><div class="td_social_type td-pb-margin-side td_social_facebook"><div class="td-social-box"><div class="td-sp td-sp-facebook"></div><span class="td_social_info">7,104</span><span class="td_social_info td_social_info_name">Fans</span><span class="td_social_button"><a href="https://www.facebook.com/flcourier"  target="_blank" >Like</a></span></div></div><div class="td_social_type td-pb-margin-side td_social_twitter"><div class="td-social-box"><div class="td-sp td-sp-twitter"></div><span class="td_social_info">687</span><span class="td_social_info td_social_info_name">Followers</span><span class="td_social_button"><a href="https://twitter.com/flcourier"  target="_blank" >Follow</a></span></div></div></div></div> <!-- ./block --><div class="td_block_wrap td_block_7 td_block_widget td_uid_8_5d1af1a5c9dbd_rand td-pb-border-top td_block_template_1 td-column-1 td_block_padding"  data-td-block-uid="td_uid_8_5d1af1a5c9dbd" ><script>var block_td_uid_8_5d1af1a5c9dbd = new tdBlock();
block_td_uid_8_5d1af1a5c9dbd.id = "td_uid_8_5d1af1a5c9dbd";
block_td_uid_8_5d1af1a5c9dbd.atts = '{"limit":"4","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"11","category_ids":"","custom_title":"WORLD","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"#","header_text_color":"#","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_block_widget td_uid_8_5d1af1a5c9dbd_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_8_5d1af1a5c9dbd_rand","tdc_css_class_style":"td_uid_8_5d1af1a5c9dbd_rand_style","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":"","block_template_id":""}';
block_td_uid_8_5d1af1a5c9dbd.td_column_number = "1";
block_td_uid_8_5d1af1a5c9dbd.block_type = "td_block_7";
block_td_uid_8_5d1af1a5c9dbd.post_count = "4";
block_td_uid_8_5d1af1a5c9dbd.found_posts = "179";
block_td_uid_8_5d1af1a5c9dbd.header_color = "#";
block_td_uid_8_5d1af1a5c9dbd.ajax_pagination_infinite_stop = "";
block_td_uid_8_5d1af1a5c9dbd.max_num_pages = "45";
tdBlocksArray.push(block_td_uid_8_5d1af1a5c9dbd);
</script><div class="td-block-title-wrap"><h4 class="block-title"><span class="td-pulldown-size">WORLD</span></h4></div><div id=td_uid_8_5d1af1a5c9dbd class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="http://flcourier.com/spacex-launches-falcon-heavy-for-the-third-time/" rel="bookmark" title="SpaceX launches Falcon Heavy for the third time"><img width="100" height="70" class="entry-thumb" src="http://flcourier.com/wp-content/uploads/2019/06/FC-SPACEX-100x70.jpg" srcset="http://flcourier.com/wp-content/uploads/2019/06/FC-SPACEX-100x70.jpg 100w, http://flcourier.com/wp-content/uploads/2019/06/FC-SPACEX-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="SpaceX launches Falcon Heavy for the third time"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://flcourier.com/spacex-launches-falcon-heavy-for-the-third-time/" rel="bookmark" title="SpaceX launches Falcon Heavy for the third time">SpaceX launches Falcon Heavy for the third time</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-06-25T20:41:44+00:00" >June 25, 2019</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="http://flcourier.com/before-apollo-11-four-missions-charted-path-for-moon-landing/" rel="bookmark" title="Before Apollo 11, four missions charted path for moon landing"><img width="100" height="70" class="entry-thumb" src="http://flcourier.com/wp-content/uploads/2019/06/FC-apollo-moon-100x70.jpg" srcset="http://flcourier.com/wp-content/uploads/2019/06/FC-apollo-moon-100x70.jpg 100w, http://flcourier.com/wp-content/uploads/2019/06/FC-apollo-moon-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Before Apollo 11, four missions charted path for moon landing"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://flcourier.com/before-apollo-11-four-missions-charted-path-for-moon-landing/" rel="bookmark" title="Before Apollo 11, four missions charted path for moon landing">Before Apollo 11, four missions charted path for moon landing</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-06-25T02:58:08+00:00" >June 25, 2019</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="http://flcourier.com/trump-u-s-was-cocked-and-loaded-against-iran/" rel="bookmark" title="Trump: U.S. was ‘cocked and loaded’ against Iran"><img width="100" height="70" class="entry-thumb" src="http://flcourier.com/wp-content/uploads/2019/06/FC-Trump-and-Bolton-100x70.jpg" srcset="http://flcourier.com/wp-content/uploads/2019/06/FC-Trump-and-Bolton-100x70.jpg 100w, http://flcourier.com/wp-content/uploads/2019/06/FC-Trump-and-Bolton-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Trump: U.S. was ‘cocked and loaded’ against Iran"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://flcourier.com/trump-u-s-was-cocked-and-loaded-against-iran/" rel="bookmark" title="Trump: U.S. was ‘cocked and loaded’ against Iran">Trump: U.S. was ‘cocked and loaded’ against Iran</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-06-22T00:05:34+00:00" >June 22, 2019</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="http://flcourier.com/study-finds-most-of-the-world-failing-at-gender-equality/" rel="bookmark" title="Study finds most of the world failing at gender equality"><img width="100" height="70" class="entry-thumb" src="http://flcourier.com/wp-content/uploads/2019/06/FC-gender-equality-100x70.jpg" srcset="http://flcourier.com/wp-content/uploads/2019/06/FC-gender-equality-100x70.jpg 100w, http://flcourier.com/wp-content/uploads/2019/06/FC-gender-equality-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Study finds most of the world failing at gender equality"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://flcourier.com/study-finds-most-of-the-world-failing-at-gender-equality/" rel="bookmark" title="Study finds most of the world failing at gender equality">Study finds most of the world failing at gender equality</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-06-10T19:38:55+00:00" >June 10, 2019</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 --></div></div> <!-- ./block -->                                </div>
                            </div>
                                    </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->


<!-- Instagram -->


<div class="td-main-content-wrap td-footer-instagram-container td-container-wrap ">
    
    <div class="td-instagram-user">
        <h4 class="td-footer-instagram-title">
            Follow us on Instagram            <a class="td-footer-instagram-user-link" href="https://www.instagram.com/flcourier" target="_blank">@flcourier</a>
        </h4>
    </div>

    <div class="td_block_wrap td_block_instagram td_uid_9_5d1af1a5d7329_rand td-pb-border-top td_block_template_1"  data-td-block-uid="td_uid_9_5d1af1a5d7329" ><div class="td-block-title-wrap"></div><div id=td_uid_9_5d1af1a5d7329 class="td-instagram-wrap td_block_inner td-column-1"></div></div> <!-- ./block --></div>



<!-- Footer -->
<div class="td-footer-wrapper td-container-wrap td-footer-template-4 ">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
                <div class="td-a-rec td-a-rec-id-footer_top  td_uid_10_5d1af1a63dd49_rand td_block_template_1"><!-- Florida Courier Wells Fargo Prepare to Prosper 728x90 BTF [async] -->
<script type="text/javascript">if (!window.AdButler){(function(){var s = document.createElement("script"); s.async = true; s.type = "text/javascript";s.src = 'https://servedbyadbutler.com/app.js';var n = document.getElementsByTagName("script")[0]; n.parentNode.insertBefore(s, n);}());}</script>
<script type="text/javascript">
var AdButler = AdButler || {}; AdButler.ads = AdButler.ads || [];
var abkw = window.abkw || '';
var plc318610 = window.plc318610 || 0;
document.write('<'+'div id="placement_318610_'+plc318610+'"></'+'div>');
AdButler.ads.push({handler: function(opt){ AdButler.register(168170, 318610, [728,90], 'placement_318610_'+opt.place, opt); }, opt: { place: plc318610++, keywords: abkw, domain: 'servedbyadbutler.com', click:'CLICK_MACRO_PLACEHOLDER' }});
</script></div>		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span12">
                <div class="td-footer-info"><div class="footer-logo-wrap"><a href="http://flcourier.com/"><img src="http://flcourier.com/wp-content/uploads/2015/03/FClogo-www970px-e1445307246565.jpg" alt="FLORIDA COURIER" title="Sharing Black Life, Statewide"/></a></div><div class="footer-text-wrap">Your credible, reliable resource of news and information affecting African-American communities across the state of Florida, USA.<div class="footer-email-wrap">Contact us: <a href="mailto:news@flcourier.com">news@flcourier.com</a></div></div><div class="footer-social-wrap td-social-style-2">
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/flcourier/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/flcourier" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div></div><aside class="td_block_template_1 widget widget_archive"><h4 class="block-title"><span>Florida Courier archives</span></h4>		<ul>
				<li><a href='http://flcourier.com/2019/07/'>July 2019</a></li>
	<li><a href='http://flcourier.com/2019/06/'>June 2019</a></li>
	<li><a href='http://flcourier.com/2019/05/'>May 2019</a></li>
	<li><a href='http://flcourier.com/2019/04/'>April 2019</a></li>
	<li><a href='http://flcourier.com/2019/03/'>March 2019</a></li>
	<li><a href='http://flcourier.com/2019/02/'>February 2019</a></li>
	<li><a href='http://flcourier.com/2019/01/'>January 2019</a></li>
	<li><a href='http://flcourier.com/2018/11/'>November 2018</a></li>
	<li><a href='http://flcourier.com/2018/10/'>October 2018</a></li>
	<li><a href='http://flcourier.com/2018/09/'>September 2018</a></li>
	<li><a href='http://flcourier.com/2018/04/'>April 2018</a></li>
	<li><a href='http://flcourier.com/2018/03/'>March 2018</a></li>
	<li><a href='http://flcourier.com/2018/02/'>February 2018</a></li>
	<li><a href='http://flcourier.com/2018/01/'>January 2018</a></li>
	<li><a href='http://flcourier.com/2017/12/'>December 2017</a></li>
	<li><a href='http://flcourier.com/2017/11/'>November 2017</a></li>
	<li><a href='http://flcourier.com/2017/10/'>October 2017</a></li>
	<li><a href='http://flcourier.com/2017/09/'>September 2017</a></li>
	<li><a href='http://flcourier.com/2017/08/'>August 2017</a></li>
	<li><a href='http://flcourier.com/2017/07/'>July 2017</a></li>
	<li><a href='http://flcourier.com/2017/06/'>June 2017</a></li>
	<li><a href='http://flcourier.com/2017/05/'>May 2017</a></li>
	<li><a href='http://flcourier.com/2017/04/'>April 2017</a></li>
	<li><a href='http://flcourier.com/2017/03/'>March 2017</a></li>
	<li><a href='http://flcourier.com/2017/02/'>February 2017</a></li>
	<li><a href='http://flcourier.com/2017/01/'>January 2017</a></li>
	<li><a href='http://flcourier.com/2016/12/'>December 2016</a></li>
	<li><a href='http://flcourier.com/2016/11/'>November 2016</a></li>
	<li><a href='http://flcourier.com/2016/10/'>October 2016</a></li>
	<li><a href='http://flcourier.com/2016/09/'>September 2016</a></li>
	<li><a href='http://flcourier.com/2016/08/'>August 2016</a></li>
	<li><a href='http://flcourier.com/2016/07/'>July 2016</a></li>
	<li><a href='http://flcourier.com/2016/06/'>June 2016</a></li>
	<li><a href='http://flcourier.com/2016/05/'>May 2016</a></li>
	<li><a href='http://flcourier.com/2016/04/'>April 2016</a></li>
	<li><a href='http://flcourier.com/2016/03/'>March 2016</a></li>
	<li><a href='http://flcourier.com/2016/02/'>February 2016</a></li>
	<li><a href='http://flcourier.com/2016/01/'>January 2016</a></li>
	<li><a href='http://flcourier.com/2015/12/'>December 2015</a></li>
	<li><a href='http://flcourier.com/2015/11/'>November 2015</a></li>
	<li><a href='http://flcourier.com/2015/10/'>October 2015</a></li>
	<li><a href='http://flcourier.com/2015/09/'>September 2015</a></li>
	<li><a href='http://flcourier.com/2015/08/'>August 2015</a></li>
	<li><a href='http://flcourier.com/2015/07/'>July 2015</a></li>
	<li><a href='http://flcourier.com/2015/06/'>June 2015</a></li>
	<li><a href='http://flcourier.com/2015/05/'>May 2015</a></li>
	<li><a href='http://flcourier.com/2015/04/'>April 2015</a></li>
	<li><a href='http://flcourier.com/2015/03/'>March 2015</a></li>
		</ul>
			</aside>            </div>
        </div>
    </div>
</div>

<!-- Sub Footer -->
    <div class="td-sub-footer-container td-container-wrap ">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span td-sub-footer-menu">
                                        </div>

                <div class="td-pb-span td-sub-footer-copy">
                    &copy; Copyright 2017, Central Florida Communicators Group LLC                </div>
            </div>
        </div>
    </div>
</div><!--close td-outer-wrap-->

<!-- ngg_resource_manager_marker --><script type='text/javascript' src='http://flcourier.com/wp-content/themes/Newspaper/js/tagdiv_theme.min.js?ver=8.1'></script>
<script type='text/javascript' src='http://flcourier.com/wp-includes/js/comment-reply.min.js?ver=9094be56be2cfe055c3ff006f0032250'></script>
<script type='text/javascript' src='http://flcourier.com/wp-includes/js/wp-embed.min.js?ver=9094be56be2cfe055c3ff006f0032250'></script>
<script async="async" type='text/javascript' src='http://flcourier.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.2'></script>


    <!--

        Theme: Newspaper by tagDiv.com 2017
        Version: 8.1 (rara)
        Deploy mode: deploy
        
        uid: 5d1af1a6420f4
    -->

    
<!-- JS generated by theme -->

<script>
    

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'http://flcourier.com/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'http://flcourier.com/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>



			<div id="tdw-css-writer" style="display: none" class="tdw-drag-dialog tdc-window-sidebar">
				<header>

				
					<a title="Editor" class="tdw-tab tdc-tab-active" href="#" data-tab-content="tdw-tab-editor">Edit with Live CSS</a>
					<div class="tdw-less-info" title="This will be red when errors are detected in your CSS and LESS"></div>
				
				</header>
				<div class="tdw-content">

					
					<div class="tdw-tabs-content tdw-tab-editor tdc-tab-content-active">


						<script>

							(function(jQuery, undefined) {

								jQuery(window).ready(function() {

									if ( 'undefined' !== typeof tdcAdminIFrameUI ) {
										var $liveIframe  = tdcAdminIFrameUI.getLiveIframe();

										if ( $liveIframe.length ) {
											$liveIframe.load(function() {
												$liveIframe.contents().find( 'body').append( '<textarea class="tdw-css-writer-editor" style="display: none"></textarea>' );
											});
										}
									}

								});

							})(jQuery);

						</script>


						<textarea class="tdw-css-writer-editor td_live_css_uid_1_5d1af1a642a07"></textarea>
						<div id="td_live_css_uid_1_5d1af1a642a07" class="td-code-editor"></div>


						<script>
							jQuery(window).load(function (){

								if ( 'undefined' !== typeof tdLiveCssInject ) {

									tdLiveCssInject.init();


									var editor_textarea = jQuery('.td_live_css_uid_1_5d1af1a642a07');
									var languageTools = ace.require("ace/ext/language_tools");
									var tdcCompleter = {
										getCompletions: function (editor, session, pos, prefix, callback) {
											if (prefix.length === 0) {
												callback(null, []);
												return
											}

											if ('undefined' !== typeof tdcAdminIFrameUI) {

												var data = {
													error: undefined,
													getShortcode: ''
												};

												tdcIFrameData.getShortcodeFromData(data);

												if (!_.isUndefined(data.error)) {
													tdcDebug.log(data.error);
												}

												if (!_.isUndefined(data.getShortcode)) {

													var regex = /el_class=\"([A-Za-z0-9_-]*\s*)+\"/g,
														results = data.getShortcode.match(regex);

													var elClasses = {};

													for (var i = 0; i < results.length; i++) {
														var currentClasses = results[i]
															.replace('el_class="', '')
															.replace('"', '')
															.split(' ');

														for (var j = 0; j < currentClasses.length; j++) {
															if (_.isUndefined(elClasses[currentClasses[j]])) {
																elClasses[currentClasses[j]] = '';
															}
														}
													}

													var arrElClasses = [];

													for (var prop in elClasses) {
														arrElClasses.push(prop);
													}

													callback(null, arrElClasses.map(function (item) {
														return {
															name: item,
															value: item,
															meta: 'in_page'
														}
													}));
												}
											}
										}
									};
									languageTools.addCompleter(tdcCompleter);

									window.editor = ace.edit("td_live_css_uid_1_5d1af1a642a07");

									// 'change' handler is written as function because it's called by tdc_on_add_css_live_components (of wp_footer hook)
									// We did it to reattach the existing compiled css to the new content received from server.
									window.editorChangeHandler = function () {
										//tdwState.lessWasEdited = true;

										window.onbeforeunload = function () {
											if (tdwState.lessWasEdited) {
												return "You have attempted to leave this page. Are you sure?";
											}
											return false;
										};

										var editorValue = editor.getSession().getValue();

										editor_textarea.val(editorValue);

										if ('undefined' !== typeof tdcAdminIFrameUI) {
											tdcAdminIFrameUI.getLiveIframe().contents().find('.tdw-css-writer-editor:first').val(editorValue);

											// Mark the content as modified
											// This is important for showing info when composer closes
                                            tdcMain.setContentModified();
										}

										tdLiveCssInject.less();
									};

									editor.getSession().setValue(editor_textarea.val());
									editor.getSession().on('change', editorChangeHandler);

									editor.setTheme("ace/theme/textmate");
									editor.setShowPrintMargin(false);
									editor.getSession().setMode("ace/mode/less");
									editor.setOptions({
										enableBasicAutocompletion: true,
										enableSnippets: true,
										enableLiveAutocompletion: false
									});

								}

							});
						</script>

					</div>
				</div>

				<footer>

					
						<a href="#" class="tdw-save-css">Save</a>
						<div class="tdw-more-info-text">Write CSS OR LESS and hit save. CTRL + SPACE for auto-complete.</div>

					
					<div class="tdw-resize"></div>
				</footer>
			</div>
			
</body>
</html>