<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head profile="http://gmpg.org/xfn/11">

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
	
<title>  Pro-war, ‘GOP-Lite’ Democrats smear Jill Stein | Florida Courier</title>

	<link rel="stylesheet" type="text/css" media="all" href="http://flcourier.com/wp-content/themes/newspro37/style.css" />
	
	<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="http://flcourier.com/feed/" />	
	<link rel="pingback" href="http://flcourier.com/xmlrpc.php" />

	<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Florida Courier &raquo; Feed" href="http://flcourier.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Florida Courier &raquo; Comments Feed" href="http://flcourier.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Florida Courier &raquo; Pro-war, ‘GOP-Lite’ Democrats smear Jill Stein Comments Feed" href="http://flcourier.com/2017/08/pro-war-gop-lite-democrats-smear-jill-stein/feed/" />
<meta property="og:description" content="Related storiesOctober 6, 2016 Here’s why Black people should vote GreenAugust 11, 2016 To serve Clinton, Ben Jealous slimes Jill SteinAugust 18, 2016 Why liberals hate the Green PartyDecember 23, 2016 Go to D.C. to fight for Black self-determinationApril 21, 2017 Trump joins Democrats in the ‘War Party’"/><meta property="og:title" content="Pro-war, ‘GOP-Lite’ Democrats smear Jill Stein"/><meta property="og:type" content="article"/><meta property="og:url" content="http://flcourier.com/2017/08/pro-war-gop-lite-democrats-smear-jill-stein/"/><meta property="og:site_name" content="Florida Courier"/><meta property="og:image" content=""/>
<!-- This site is powered by Shareaholic - https://shareaholic.com -->
<script type='text/javascript' data-cfasync='false'>
  //<![CDATA[
    _SHR_SETTINGS = {"endpoints":{"local_recs_url":"http:\/\/flcourier.com\/wp-admin\/admin-ajax.php?action=shareaholic_permalink_related","share_counts_url":"http:\/\/flcourier.com\/wp-admin\/admin-ajax.php?action=shareaholic_share_counts_api"}};
  //]]>
</script>
<script type='text/javascript' data-cfasync='false'
        src='//dsms0mj1bbhn4.cloudfront.net/assets/pub/shareaholic.js'
        data-shr-siteid='0900cb9ecff269ed0addfaecaa3370da' async='async' >
</script>

<!-- Shareaholic Content Tags -->
<meta name='shareaholic:site_name' content='Florida Courier' />
<meta name='shareaholic:language' content='en-US' />
<meta name='shareaholic:url' content='http://flcourier.com/2017/08/pro-war-gop-lite-democrats-smear-jill-stein/' />
<meta name='shareaholic:keywords' content='columnists, commentaries' />
<meta name='shareaholic:article_published_time' content='2017-08-03T22:29:16+00:00' />
<meta name='shareaholic:article_modified_time' content='2017-08-03T22:57:53+00:00' />
<meta name='shareaholic:shareable_page' content='true' />
<meta name='shareaholic:article_author_name' content='FCEditor' />
<meta name='shareaholic:site_id' content='0900cb9ecff269ed0addfaecaa3370da' />
<meta name='shareaholic:wp_version' content='7.8.0.4' />
<meta name='shareaholic:image' content='http://flcourier.com/wp-content/uploads/2015/05/00-margaretkimberly.jpg' />
<!-- Shareaholic Content Tags End -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/flcourier.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=d12ca89124d66702822d93b1aa0a4aa3"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='gabfire-widget-css-css'  href='http://flcourier.com/wp-content/plugins/gabfire-widget-pack/css/style.css?ver=d12ca89124d66702822d93b1aa0a4aa3' type='text/css' media='all' />
<script type='text/javascript' src='http://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js?ver=d12ca89124d66702822d93b1aa0a4aa3'></script>
<script type='text/javascript' src='http://flcourier.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://flcourier.com/wp-content/themes/newspro37/inc/js/slides.min.jquery.js?ver=d12ca89124d66702822d93b1aa0a4aa3'></script>
<script type='text/javascript' src='http://flcourier.com/wp-content/themes/newspro37/inc/js/jquery.tools.min.js?ver=d12ca89124d66702822d93b1aa0a4aa3'></script>
<script type='text/javascript' src='http://flcourier.com/wp-content/themes/newspro37/inc/js/flowplayer/flowplayer-3.2.6.min.js?ver=d12ca89124d66702822d93b1aa0a4aa3'></script>
<script type='text/javascript' src='http://flcourier.com/wp-content/themes/newspro37/inc/js/superfish-1.4.8.js?ver=d12ca89124d66702822d93b1aa0a4aa3'></script>
<link rel='https://api.w.org/' href='http://flcourier.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://flcourier.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://flcourier.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Trump faces down CIA, co-opts Pentagon' href='http://flcourier.com/2017/08/trump-faces-down-cia-co-opts-pentagon/' />
<link rel='next' title='All Putin has to show for his meddling is more sanctions' href='http://flcourier.com/2017/08/all-putin-has-to-show-for-his-meddling-is-more-sanctions/' />

<link rel="canonical" href="http://flcourier.com/2017/08/pro-war-gop-lite-democrats-smear-jill-stein/" />
<link rel='shortlink' href='http://flcourier.com/?p=13897' />
<link rel="alternate" type="application/json+oembed" href="http://flcourier.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fflcourier.com%2F2017%2F08%2Fpro-war-gop-lite-democrats-smear-jill-stein%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://flcourier.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fflcourier.com%2F2017%2F08%2Fpro-war-gop-lite-democrats-smear-jill-stein%2F&#038;format=xml" />
<!-- <meta name="NextGEN" version="2.2.12" /> -->
<script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//flcourier.com/?wordfence_logHuman=1&hid=20F653A48D1D9D0002E660B154D65F50');
</script><script type="text/javascript">
	window._wp_rp_static_base_url = 'https://wprp.zemanta.com/static/';
	window._wp_rp_wp_ajax_url = "http://flcourier.com/wp-admin/admin-ajax.php";
	window._wp_rp_plugin_version = '3.6.4';
	window._wp_rp_post_id = '13897';
	window._wp_rp_num_rel_posts = '5';
	window._wp_rp_thumbnails = true;
	window._wp_rp_post_title = 'Pro-war%2C+%E2%80%98GOP-Lite%E2%80%99+Democrats+smear+Jill+Stein';
	window._wp_rp_post_tags = ['columnists', 'commentaries', 'parti', 'hillari', 'georg', 'war', 'polit', 'clinton', 'donald', 'green', 'russia', 'vladimir', 'tabl', 'putin', 'stein', 'democrat', 'jill'];
	window._wp_rp_promoted_content = true;
</script>
<link rel="stylesheet" href="http://flcourier.com/wp-content/plugins/wordpress-23-related-posts-plugin/static/themes/momma.css?version=3.6.4" />
<link href="http://flcourier.com/wp-content/themes/newspro37/styles/red.css" rel="stylesheet" type="text/css" />

	<script type='text/javascript'>
	(function($) {
		$(document).ready(function() { 
			
							$('#slides').slides({
										autoHeight: true
				});
						$("ul.tabs").tabs("div.panes > div");
			$("ul.sc_tabs").tabs("div.sc_tabs-content > div");
			$('a[href=#top]').click(function(){	$('html, body').animate({scrollTop:0}, 'slow');	return false;});
		});
	})(jQuery);
	</script>
<link rel="shortcut icon" href="http://flcourier.com/wp-content/uploads/2015/03/FCfavicon.png"/>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-20957626-1', 'auto');
  ga('send', 'pageview');

</script>
	
	
		

</head>

<body class="post-template-default single single-post postid-13897 single-format-standard">

<div id="wrapper">
	
	<div id="header">	
		<div id="masthead">
			<ul class="nav_masthead dropdown">					
									<li><a class="gab_rss" href="http://flcourier.com/feed/" rel="nofollow" title="Subscribe to latest posts in RSS">RSS for Posts</a></li>
					
										
											<li><a class="gab_twitter" href="http://twitter.com/flcourier" rel="nofollow" title="follow on twitter">Follow on Twitter</a></li>
										
											<li><a class="gab_facebook" href="http://facebook.com/flcourier" rel="nofollow" title="Connect on facebook">Connect on Facebook</a></li>
												 </ul>

			<div id="search">
				<form id="searchform" action="http://flcourier.com/">
	<fieldset>
		<input type="text" id="s" name="s" value="Search in site..." onfocus="if(this.value==this.defaultValue)this.value='';" onblur="if(this.value=='')this.value=this.defaultValue;"/>
		<input type="image" id="searchsubmit" src="http://flcourier.com/wp-content/themes/newspro37/images/button_go.gif" alt="Search in site..." /> 
	</fieldset>
</form>
			</div><!-- /search -->
			<div class="clear"></div>
		</div>

				
		<div id="logo" style="padding:15px 0 10px 0px;">
		
							<a href="http://flcourier.com/" title="Sharing Black Life, Statewide">
					<img src="http://flcourier.com/wp-content/uploads/2015/03/fc_logo7281.jpg" alt="Florida Courier" title="Florida Courier"/>
				</a>
					</div><!-- /logo -->
		
		<div id="banner" style="padding-top:20px">
					</div>
			
			</div><!-- /header -->
	
	<div class="clear"></div>		
	
	<div id="mainmenu">
		<ul class="mainnav dropdown">
			<li id="menu-item-68" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-68"><a href="http://flcourier.com/category/front-page/">FRONT PAGE</a></li>
<li id="menu-item-65" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65"><a href="http://flcourier.com/category/florida/">FLORIDA</a></li>
<li id="menu-item-70" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-70"><a href="http://flcourier.com/category/national/">NATIONAL</a></li>
<li id="menu-item-62" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-62"><a href="http://flcourier.com/category/commentaries/">COMMENTARIES</a></li>
<li id="menu-item-202" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-202"><a href="http://flcourier.com/category/metro/">METRO</a>
<ul  class="sub-menu">
	<li id="menu-item-60" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-60"><a href="http://flcourier.com/category/business/">BUSINESS</a></li>
	<li id="menu-item-63" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-63"><a href="http://flcourier.com/category/education/">EDUCATION</a></li>
	<li id="menu-item-64" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-64"><a href="http://flcourier.com/category/entertainment/">ENTERTAINMENT</a></li>
	<li id="menu-item-302" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-302"><a href="http://flcourier.com/category/health/">HEALTH</a></li>
	<li id="menu-item-67" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-67"><a href="http://flcourier.com/category/food/">FOOD</a></li>
	<li id="menu-item-72" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-72"><a href="http://flcourier.com/category/technology/">TECHNOLOGY</a></li>
</ul>
</li>
<li id="menu-item-66" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66"><a href="http://flcourier.com/category/floridas-finest/">FLORIDA&#8217;S FINEST</a></li>
<li id="menu-item-299" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-299"><a href="http://flcourier.com/category/sports/">SPORTS</a></li>
<li id="menu-item-71" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71"><a href="http://flcourier.com/category/politics/">POLITICS</a></li>
<li id="menu-item-69" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-69"><a href="http://flcourier.com/category/world/">WORLD</a></li>
		</ul>
	</div>
	
	<div id="submenu">
		<ul class="subnav dropdown">	
			<li id="menu-item-301" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-301"><a href="http://flcourier.com/community-calendar/">COMMUNITY CALENDAR</a></li>
<li id="menu-item-36" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-36"><a href="http://flcourier.com/about-us/">ABOUT US</a></li>
<li id="menu-item-39" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-39"><a href="http://flcourier.com/tribute-to-our-founder/">TRIBUTE TO OUR FOUNDER</a>
<ul  class="sub-menu">
	<li id="menu-item-46" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-46"><a href="http://flcourier.com/tribute-to-our-founder/the-life/">The Life</a></li>
	<li id="menu-item-45" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-45"><a href="http://flcourier.com/tribute-to-our-founder/the-love/">The Love</a></li>
	<li id="menu-item-43" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43"><a href="http://flcourier.com/tribute-to-our-founder/the-school/">The School</a></li>
	<li id="menu-item-42" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-42"><a href="http://flcourier.com/tribute-to-our-founder/the-influences/">The Influences</a></li>
	<li id="menu-item-44" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-44"><a href="http://flcourier.com/tribute-to-our-founder/the-family/">The Family</a></li>
	<li id="menu-item-41" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41"><a href="http://flcourier.com/tribute-to-our-founder/the-mission/">The Mission</a></li>
	<li id="menu-item-40" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40"><a href="http://flcourier.com/tribute-to-our-founder/the-mission-accomplished-and-the-charge/">The Mission Accomplished and The Charge</a></li>
</ul>
</li>
<li id="menu-item-52" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-52"><a href="http://flcourier.com/our-sister-sites/">OUR SISTER SITES</a>
<ul  class="sub-menu">
	<li id="menu-item-227" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-227"><a href="http://www.daytonatimes.com">DAYTONA TIMES</a></li>
	<li id="menu-item-228" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-228"><a href="http://www.lajefa949.com">LA JEFA 94.9FM &#038; 1070AM</a></li>
</ul>
</li>
<li id="menu-item-37" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37"><a href="http://flcourier.com/contact-us/">CONTACT US</a></li>
		 </ul>
		 <div class="clear"></div>
	</div>
	<div class="clear"></div>	<div id="container">	
		
				<div id="post-13897" class="entry post-13897 post type-post status-publish format-standard hentry category-columnists category-commentaries">
		
			<h1 class="entry_title">Pro-war, ‘GOP-Lite’ Democrats smear Jill Stein</h1>

			<div class="metasingle">
				<span class="post_date">August 3, 2017</span>
				<span class="post_cat">Filed under <a href="http://flcourier.com/category/columnists/" rel="category tag">COLUMNISTS</a>, <a href="http://flcourier.com/category/commentaries/" rel="category tag">COMMENTARIES</a> </span>
				<span class="post_author last">Posted by <a href="http://flcourier.com/author/fceditor/" title="Posts by FCEditor" rel="author">FCEditor</a></span> 
			</div><!-- /metas -->
			
			<p><img class="alignleft size-full wp-image-1075" src="http://flcourier.com/wp-content/uploads/2015/05/00-margaretkimberly.jpg" alt="" width="225" height="100">Democrats&nbsp;hate the left&nbsp;more than they hate the right. Their hatred is most evident when people who are truly on the left dare to make the case for political change.</p>
<p>When Al Gore and Hillary Clinton won the popular vote but lost presidential races in the Electoral College, Democratic Party scorn was directed solely at the Green Party and their voters. In both elections, there were far more instances of registered Democrats voting for George W. Bush and Donald Trump respectively.</p>
<p><strong>Attacked independents</strong><br />
One would think that they would be marked for condemnation. Instead, the Democrats show their true colors, excusing and placating the turncoats to make the case for “lesser evil” neo-liberalism and imperialism.</p>
<p>The “Russiagate” phenomenon makes Green Party presidential candidate Jill Stein an even bigger target. Stein visited Russia in 2015 and attended the RT Network’s anniversary dinner. She was seated at the same table with Vladimir Putin, although the two never spoke. This simple act is now being included among the flimsy so-called evidence that the Russian government interfered in the election.</p>
<p>The “war party” is an important part of the duopoly, and leading Democrats are reveling in their opportunity to make political hay. Congressman Adam Schiff is ranking minority member of the House Intelligence Committee and a leader in the charge against Russia, and now Stein.</p>
<p>It isn’t clear how Stein’s presence in Moscow impacted the election.</p>
<p><strong>Truth isn’t the point</strong><br />
Donald Trump, Jr. and others involved in his father’s campaign are now targets of investigation because of their amateurish contacts with Russian citizens. The Senate Judiciary Committee demanded that Trump the younger provide them with&nbsp;any communication&nbsp;he had with 41 individuals and entities – and they included Jill Stein’s name among them.</p>
<p>The list also includes Putin, his foreign secretary, the ambassador to the United States, the Ritz Carlton hotel and the oligarch who bankrolled Trump’s Miss Universe pageant in Moscow. Every other person, business or organization on the list is a Russian government official, played some role on the Trump campaign, or are or are mentioned in stories about election hacking.</p>
<p>There is no legitimate reason for Stein’s name to be on this list. She is being thrown under the bus in a classic smear tactic.</p>
<p><strong>Lost common sense</strong><br />
Rank-and-file Democrats have lost all sense of logic and common sense in their post-election trauma. They are always predisposed to attack anyone who points out the obvious deficiencies in the party they cling to with such devotion.</p>
<p>Ever since Election Day, they have shamefully praised the intelligence apparatus, shown love for an FBI director, and joined the chorus for war and American intervention around the world. Jill Stein is now the perfect foil. She can simultaneously be blamed for Hillary Clinton’s loss while feeding the anti-Russia frenzy.</p>
<p>It is important for the left to defend Stein at this moment. She and all Americans have a right to disagree with their government’s foreign policy. We have a right to visit any nation and interact with anyone we choose and to question presidents, Congress and elite punditry. We should be able to do so without fear of harassment or legal jeopardy.</p>
<p>The notion that Russia is a hostile power is a concoction of the corporate media and the war-loving members of the political party duopoly. If they attempt to silence or smear Stein or anyone else, they must be met with staunch opposition.</p>
<p>Margaret Kimberley’s column appears weekly in BlackAgendaReport.com.</p>
<div class='shareaholic-canvas' data-app-id='26658078' data-app='share_buttons' data-title='Pro-war, ‘GOP-Lite’ Democrats smear Jill Stein' data-link='http://flcourier.com/2017/08/pro-war-gop-lite-democrats-smear-jill-stein/' data-summary=''></div><div class='shareaholic-canvas' data-app-id='26658086' data-app='recommendations' data-title='Pro-war, ‘GOP-Lite’ Democrats smear Jill Stein' data-link='http://flcourier.com/2017/08/pro-war-gop-lite-democrats-smear-jill-stein/' data-summary=''></div>
<div class="wp_rp_wrap  wp_rp_momma" id="wp_rp_first"><div class="wp_rp_content"><h3 class="related_post_title">Related stories</h3><ul class="related_post wp_rp"><li data-position="0" data-poid="in-10573" data-post-type="none" ><a href="http://flcourier.com/2016/10/heres-why-black-people-should-vote-green/" class="wp_rp_thumbnail"><img src="http://flcourier.com/wp-content/uploads/2016/09/FClogo-www970px-150x150.jpg" alt="Here’s why Black people should vote Green" width="150" height="150" /></a><small class="wp_rp_publish_date">October 6, 2016</small> <a href="http://flcourier.com/2016/10/heres-why-black-people-should-vote-green/" class="wp_rp_title">Here’s why Black people should vote Green</a></li><li data-position="1" data-poid="in-10010" data-post-type="none" ><a href="http://flcourier.com/2016/08/to-serve-clinton-ben-jealous-slimes-jill-stein/" class="wp_rp_thumbnail"><img src="http://flcourier.com/wp-content/uploads/2015/03/Ford_Glen-300x184-150x150.jpg" alt="To serve Clinton, Ben Jealous slimes Jill Stein" width="150" height="150" /></a><small class="wp_rp_publish_date">August 11, 2016</small> <a href="http://flcourier.com/2016/08/to-serve-clinton-ben-jealous-slimes-jill-stein/" class="wp_rp_title">To serve Clinton, Ben Jealous slimes Jill Stein</a></li><li data-position="2" data-poid="in-10094" data-post-type="none" ><a href="http://flcourier.com/2016/08/why-liberals-hate-the-green-party/" class="wp_rp_thumbnail"><img src="http://flcourier.com/wp-content/uploads/2016/09/FClogo-www970px-150x150.jpg" alt="Why liberals hate  the Green Party" width="150" height="150" /></a><small class="wp_rp_publish_date">August 18, 2016</small> <a href="http://flcourier.com/2016/08/why-liberals-hate-the-green-party/" class="wp_rp_title">Why liberals hate  the Green Party</a></li><li data-position="3" data-poid="in-11395" data-post-type="none" ><a href="http://flcourier.com/2016/12/go-to-d-c-to-fight-for-black-self-determination/" class="wp_rp_thumbnail"><img src="http://flcourier.com/wp-content/uploads/2015/03/Ford_Glen-300x184-150x150.jpg" alt="Go to D.C. to fight for Black self-determination" width="150" height="150" /></a><small class="wp_rp_publish_date">December 23, 2016</small> <a href="http://flcourier.com/2016/12/go-to-d-c-to-fight-for-black-self-determination/" class="wp_rp_title">Go to D.C. to fight for Black self-determination</a></li><li data-position="4" data-poid="in-12670" data-post-type="none" ><a href="http://flcourier.com/2017/04/trump-joins-democrats-in-the-war-party/" class="wp_rp_thumbnail"><img src="http://flcourier.com/wp-content/uploads/2016/09/FClogo-www970px-150x150.jpg" alt="Trump joins Democrats in the ‘War Party’" width="150" height="150" /></a><small class="wp_rp_publish_date">April 21, 2017</small> <a href="http://flcourier.com/2017/04/trump-joins-democrats-in-the-war-party/" class="wp_rp_title">Trump joins Democrats in the ‘War Party’</a></li></ul></div></div>
<div class="clear"></div>		
			
							<div class="author single_postmeta">

					<img alt='' src='http://0.gravatar.com/avatar/9e3a72174948a1e2cca810760be00e9e?s=68&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/9e3a72174948a1e2cca810760be00e9e?s=136&amp;d=mm&amp;r=g 2x' class='avatar avatar-68 photo' height='68' width='68' />					<strong>About FCEditor</strong><br />
										<br />
					<a href="http://flcourier.com/author/fceditor/">
						View all posts by FCEditor &rarr;					</a>
				</div>
					
					</div><!-- /post -->

		
<div id="comments">
	
	
	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/08/pro-war-gop-lite-democrats-smear-jill-stein/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="http://flcourier.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='13897' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="4c218b6d47" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="241"/></p>			</form>
			</div><!-- #respond -->
	
	
</div><!-- #comments -->	</div><!-- /container -->
	

	<div id="sidebar">
		<div id="text-17" class="widget widget_text">			<div class="textwidget"><p><!--/* OpenX JavaScript tag */--></p>
<p><script type="text/javascript">
if (!window.OX_ads) { OX_ads = []; }
OX_ads.push({ "auid" : "537995206" });
</script><br />
<iframe id="c7a98afd6b" src="//mirrordigital-d.openx.net/w/1.0/afr?auid=537995206&amp;cb=INSERT_RANDOM_NUMBER_HERE" name="c7a98afd6b" width="300" height="250" frameborder="0" scrolling="no">&lt;a href=&#8221;//mirrordigital-d.openx.net/w/1.0/rc?cs=c7a98afd6b&amp;amp;cb=INSERT_RANDOM_NUMBER_HERE&#8221; data-mce-href=&#8221;//mirrordigital-d.openx.net/w/1.0/rc?cs=c7a98afd6b&amp;amp;cb=INSERT_RANDOM_NUMBER_HERE&#8221;&gt;&lt;img src=&#8221;//mirrordigital-d.openx.net/w/1.0/ai?auid=537995206&amp;amp;cs=c7a98afd6b&amp;amp;cb=INSERT_RANDOM_NUMBER_HERE&#8221; alt=&#8221;&#8221; data-mce-src=&#8221;//mirrordigital-d.openx.net/w/1.0/ai?auid=537995206&amp;amp;cs=c7a98afd6b&amp;amp;cb=INSERT_RANDOM_NUMBER_HERE&#8221; /&gt;&lt;/a&gt;</iframe></p>
</div>
		</div>
<div id="gabfire_share_widget-3" class="widget gabfire_share_widget"><h3 class="widgettitle">Share this story</h3>
<div class="gab_share_boxes"><div class="google-share-box"><div class="g-plusone" data-size="tall"></div></div><div class="facebook-share-box"><div class="fb-like" data-href="http://flcourier.com/2017/08/pro-war-gop-lite-democrats-smear-jill-stein/" data-send="false" data-layout="box_count" data-width="65" data-show-faces="false"></div>
						</div><div class="twitter-share-box"><a href="https://twitter.com/share" class="twitter-share-button" data-url="http://flcourier.com/2017/08/pro-war-gop-lite-democrats-smear-jill-stein/" data-counturl="http://flcourier.com/2017/08/pro-war-gop-lite-democrats-smear-jill-stein/" data-text="Pro-war, ‘GOP-Lite’ Democrats smear Jill Stein" data-lang="en" data-related="anywhereTheJavascriptAPI" data-count="vertical">Tweet</a></div><div class="linkedin-share-box"><script type="IN/Share" data-url="www.gabfirethemes.com" data-counter="top"></script></div><div class="pinterest-share-box"><a href="http://pinterest.com/pin/create/button/?url=http%3A%2F%2Fflcourier.com%2F2017%2F08%2Fpro-war-gop-lite-democrats-smear-jill-stein%2F&media=&description=Democrats&nbsp;hate the left&nbsp;more than they hate the right. Their hatred is most evident when people who are truly on the left dare to make the case for political change. When Al Gore and Hillary Clinton won the popular vote but lost presidential races in the Electoral College, Democratic Party scorn was directed solely at the [&hellip;]" class="pin-it-button" count-layout="horizontal"><img border="0" src="//assets.pinterest.com/images/PinExt.png" title="Pin It" /></a></div></div><div class="clearfix"></div><a target="_blank" rel="nofollow" class="facebook" href="http://www.facebook.com/share.php?u=http://flcourier.com/2017/08/pro-war-gop-lite-democrats-smear-jill-stein/&t=Pro-war, ‘GOP-Lite’ Democrats smear Jill Stein" title="Share on Facebook ">Facebook</a><a target="_blank" rel="nofollow" class="twitter" href="http://twitter.com/home?status=Pro-war, ‘GOP-Lite’ Democrats smear Jill Stein http://flcourier.com/2017/08/pro-war-gop-lite-democrats-smear-jill-stein/" title="Share on Twitter ">Twitter</a><a target="_blank" rel="nofollow" class="plus1" href="https://plusone.google.com/_/+1/confirm?hl=en&url=http://flcourier.com/2017/08/pro-war-gop-lite-democrats-smear-jill-stein/" title="Share on Google1 ">Google1</a><a target="_blank" rel="nofollow" class="email" href="mailto:?subject=Florida%20Courier%20%3A%20Pro-war%2C%20%E2%80%98GOP-Lite%E2%80%99%20Democrats%20smear%20Jill%20Stein&amp;body=I%20recommend%20this%20page%3A%20Pro-war%2C%20%E2%80%98GOP-Lite%E2%80%99%20Democrats%20smear%20Jill%20Stein.%0AYou%20can%20read%20it%20on%3A%20http%3A%2F%2Fflcourier.com%2F2017%2F08%2Fpro-war-gop-lite-democrats-smear-jill-stein%2F" title="Email a Friend : Pro-war, ‘GOP-Lite’ Democrats smear Jill Stein">Email</a><a target="_blank" rel="nofollow" class="delicious" href="https://delicious.com/post?url=http://flcourier.com/2017/08/pro-war-gop-lite-democrats-smear-jill-stein/&title=Pro-war, ‘GOP-Lite’ Democrats smear Jill Stein" title="Share on Delicious ">Delicious</a><a target="_blank" rel="nofollow" class="digg" href="http://digg.com/submit?url=http://flcourier.com/2017/08/pro-war-gop-lite-democrats-smear-jill-stein/&title=Pro-war, ‘GOP-Lite’ Democrats smear Jill Stein" title="Share on Digg ">Digg</a><a target="_blank" rel="nofollow" class="google2" href="http://www.google.com/bookmarks/mark?op=add&bkmk=http://flcourier.com/2017/08/pro-war-gop-lite-democrats-smear-jill-stein/&title=Pro-war, ‘GOP-Lite’ Democrats smear Jill Stein" title="Share on Google ">Google</a><a target="_blank" rel="nofollow" class="stumbleupon" href="http://www.stumbleupon.com/submit?url=http://flcourier.com/2017/08/pro-war-gop-lite-democrats-smear-jill-stein/&title=Pro-war, ‘GOP-Lite’ Democrats smear Jill Stein" title="Share on StumbleUpon ">Stumbleupon</a><a target="_blank" rel="nofollow" class="reddit" href="http://reddit.com/submit?url=http://flcourier.com/2017/08/pro-war-gop-lite-democrats-smear-jill-stein/&title=Pro-war, ‘GOP-Lite’ Democrats smear Jill Stein" title="Share on Reddit ">Reddit</a><a target="_blank" rel="nofollow" class="technorati" href="http://technorati.com/faves?sub=favthis&add=http://flcourier.com/2017/08/pro-war-gop-lite-democrats-smear-jill-stein/" title="Share on Technorati ">Technorati</a><a target="_blank" rel="nofollow" class="yahoo" href="http://buzz.yahoo.com/buzz?targetUrl=http://flcourier.com/2017/08/pro-war-gop-lite-democrats-smear-jill-stein/&headline=Pro-war, ‘GOP-Lite’ Democrats smear Jill Stein" title="Share on Yahoo ">Yahoo</a><a target="_blank" rel="nofollow" class="blogger" href="http://www.blogger.com/blog_this.pyra?t&u=http://flcourier.com/2017/08/pro-war-gop-lite-democrats-smear-jill-stein/&n=Pro-war, ‘GOP-Lite’ Democrats smear Jill Stein&pli=1" title="Share on Blogger ">Blogger</a><a target="_blank" rel="nofollow" class="myspace" href="http://www.myspace.com/Modules/PostTo/Pages/?u=http://flcourier.com/2017/08/pro-war-gop-lite-democrats-smear-jill-stein/&t=Pro-war, ‘GOP-Lite’ Democrats smear Jill Stein&c=http://flcourier.com/2017/08/pro-war-gop-lite-democrats-smear-jill-stein/" title="Share on Myspace ">Myspace</a><a target="_blank" rel="nofollow" class="rss" href="http://flcourier.com/2017/08/pro-war-gop-lite-democrats-smear-jill-stein/feed/" title="RSS Feed ">RSS</a><div class="clear clearfix"></div><div class='clear'></div></div>
 
	</div><!-- End of sidebar -->

	<div class="clear"></div>

</div><!-- enf od wrapper -->

</div><!-- end of wrapper -->

<div id="footer">

	<div id="foo_widget1">
		<div id="archives-4" class="widget widget_archive"><h3 class="widgettitle">Florida Courier archives</h3>
		<ul>
			<li><a href='http://flcourier.com/2017/08/'>August 2017</a></li>
	<li><a href='http://flcourier.com/2017/07/'>July 2017</a></li>
	<li><a href='http://flcourier.com/2017/06/'>June 2017</a></li>
	<li><a href='http://flcourier.com/2017/05/'>May 2017</a></li>
	<li><a href='http://flcourier.com/2017/04/'>April 2017</a></li>
	<li><a href='http://flcourier.com/2017/03/'>March 2017</a></li>
	<li><a href='http://flcourier.com/2017/02/'>February 2017</a></li>
	<li><a href='http://flcourier.com/2017/01/'>January 2017</a></li>
	<li><a href='http://flcourier.com/2016/12/'>December 2016</a></li>
	<li><a href='http://flcourier.com/2016/11/'>November 2016</a></li>
	<li><a href='http://flcourier.com/2016/10/'>October 2016</a></li>
	<li><a href='http://flcourier.com/2016/09/'>September 2016</a></li>
	<li><a href='http://flcourier.com/2016/08/'>August 2016</a></li>
	<li><a href='http://flcourier.com/2016/07/'>July 2016</a></li>
	<li><a href='http://flcourier.com/2016/06/'>June 2016</a></li>
	<li><a href='http://flcourier.com/2016/05/'>May 2016</a></li>
	<li><a href='http://flcourier.com/2016/04/'>April 2016</a></li>
	<li><a href='http://flcourier.com/2016/03/'>March 2016</a></li>
	<li><a href='http://flcourier.com/2016/02/'>February 2016</a></li>
	<li><a href='http://flcourier.com/2016/01/'>January 2016</a></li>
	<li><a href='http://flcourier.com/2015/12/'>December 2015</a></li>
	<li><a href='http://flcourier.com/2015/11/'>November 2015</a></li>
	<li><a href='http://flcourier.com/2015/10/'>October 2015</a></li>
	<li><a href='http://flcourier.com/2015/09/'>September 2015</a></li>
	<li><a href='http://flcourier.com/2015/08/'>August 2015</a></li>
	<li><a href='http://flcourier.com/2015/07/'>July 2015</a></li>
	<li><a href='http://flcourier.com/2015/06/'>June 2015</a></li>
	<li><a href='http://flcourier.com/2015/05/'>May 2015</a></li>
	<li><a href='http://flcourier.com/2015/04/'>April 2015</a></li>
	<li><a href='http://flcourier.com/2015/03/'>March 2015</a></li>
		</ul>
		</div>
	</div>

	<div id="foo_widget2">
		<div id="meta-2" class="widget widget_meta"><h3 class="widgettitle">Meta</h3>
			<ul>
						<li><a href="http://flcourier.com/wp-login.php">Log in</a></li>
			<li><a href="http://flcourier.com/feed/">Entries <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="http://flcourier.com/comments/feed/">Comments <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://wordpress.org/" title="Powered by WordPress, state-of-the-art semantic personal publishing platform.">WordPress.org</a></li>			</ul>
			</div>
		<div class="clear"></div>
	</div>
	
	<div id="foo_widget3">	
				
			<h3 class="widgettitle">Widgetized Section</h3>
			<p>Go to Admin &raquo; appearance &raquo; Widgets &raquo;  and move a widget into Footer1 Widget Zone</p>
			
			</div>

	<div class="clear"></div>
	
	<div id="foo_widget4">
				
			<h3 class="widgettitle">Widgetized Section</h3>
			<p>Go to Admin &raquo; appearance &raquo; Widgets &raquo;  and move a widget into Footer4 Widget Zone</p>
			
			</div>
	
	<div id="foo_widget5">
		<div id="text-6" class="widget widget_text">			<div class="textwidget"></div>
		</div>
	</div>

	<div class="clear"></div>
</div><!-- /footer -->

<div id="footer_data">
	<div id="footer-left-side">
					<a href="http://flcourier.com/" title="Florida Courier" rel="home">Florida Courier</a>
			</div><!-- #site-info -->
			
	<div id="footer-right-side">
		<a href="http://flcourier.com/wp-login.php">Log in</a> - 
				<a href="http://wordpress.org/" title="Semantic Personal Publishing Platform" rel="generator">Powered by WordPress</a> - 
		Designed by <a href="http://www.gabfirethemes.com/" title="Premium WordPress Themes">Gabfire Themes</a> 
		<!-- ngg_resource_manager_marker --><script type='text/javascript' src='http://flcourier.com/wp-includes/js/comment-reply.min.js?ver=d12ca89124d66702822d93b1aa0a4aa3'></script>
<script type='text/javascript' src='http://flcourier.com/wp-includes/js/wp-embed.min.js?ver=d12ca89124d66702822d93b1aa0a4aa3'></script>
<script type='text/javascript' src='http://flcourier.com/wp-content/plugins/akismet/_inc/form.js?ver=3.3.3'></script>

	<div id="fb-root"></div>
	<script type='text/javascript'>
	<!--
	(function(d, s, id) {
	  var js, fjs = d.getElementsByTagName(s)[0];
	  if (d.getElementById(id)) return;
	  js = d.createElement(s); js.id = id;
	  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
	  fjs.parentNode.insertBefore(js, fjs);
	}(document, 'script', 'facebook-jssdk'));
	// -->
	</script>		<script type="text/javascript">
			<!--
		  (function() {
			var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
			po.src = 'https://apis.google.com/js/plusone.js';
			var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
		  })();
		  // -->
		</script>
			
		<div id="fb-root"></div>
		<script type='text/javascript'>
		<!--
		(function(d, s, id) {
		  var js, fjs = d.getElementsByTagName(s)[0];
		  if (d.getElementById(id)) return;
		  js = d.createElement(s); js.id = id;
		  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
		  fjs.parentNode.insertBefore(js, fjs);
		}(document, 'script', 'facebook-jssdk'));
		// -->
		</script>
			<script type='text/javascript'>
		<!--
		!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");
		// -->
		</script>
			<script src="//platform.linkedin.com/in.js" type="text/javascript">
		lang: en_US		</script>
			<script type="text/javascript" src="//assets.pinterest.com/js/pinit.js"></script>
		<script type="text/javascript" src="//assets.pinterest.com/js/pinit.js">
		<!--
			document.body.innerHTML = document.body.innerHTML.replace(/&amp;;/g, "a");
		// -->
		</script>
		</div> <!-- #footer-right-side -->
	<div class="clear"></div>
</div><!-- /footer_data -->

</body>
</html>